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ONE

LEGAL NOTICE
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The content of this manual is not an exact description in the legal sense and is not a subject to product liability. The
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CHAPTER

TWO

INTRODUCTION

Rillsoft Project is a high-performance software tool for project management, assisting you in project scheduling, ca-
pacity planning and management resource planning.

Rillsoft Project provides the following functions for all project stages

• Project scheduling and management resource planning
– scheduling personnel resources in the form of:

∗ roles,

∗ teams,

∗ employees.

– flexibly recording of roles by different levels of qualification with graded cost rates.

– defining teams by:

∗ capacity and costs per hour,

∗ assigned employees.

– recording employees by

∗ assignation to several teams,

∗ simultaneous assignation to several roles with different qualifications, costs and stages of productivity,

∗ independent determination of non-working days (holidays, sickness).

– evaluation of available capacity and usage of roles and employees at any time.

– assigning employees on the basis of their roles and qualifications by means of an assistant program.

– entering the work result of activities (pit 180 m3).

– displaying the activity effort by entering employee days (such as 5 ED).

– describing and administering the required materials and machines.

– applying several calendar for the individual resources and a flexible scheduling.

– multiproject planning and project portfolio.

– evaluating excess and shortfall of personnel resources (supply minus demand = contingency).

– using subprojects and WBS codes to structure the project.

– viewing the project details from different perspectives.

• Project controlling and project execution analysis
– updating the project by recording the completion percentage of the activities.
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– providing a variance analysis which matches the parameters, such as time, costs and resource utilization,
of the target to those of actual.

– quickly detecting deviances from actual by means of a progress line and a baseline.

– controlling the project financing.

• Project management
conciliating the actual with the target

– assigning or reassigning employees to and from activities in the ongoing project.

– assigning personnel to critical activities, in order to speed up execution.

conciliating the target with the actual

– separating of completed activities from waiting activities.

– shifting of delayed activities to the cutoff date.

– optimising of resource utilization of not yet completed project activities.

• Reports
– Gantt chart, resource and capacity views can be exported to MS Excel.

– All views can be printed out as PDF files.
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CHAPTER

THREE

WORKING IN NETWORKS

In order to avoid conflicts between resources, all users of the network should share the same resource pool file. After
the start Rillsoft Project accesses the resource pool.

You can check below in the left corner of the status bar, where to find your resource pool.

There is a difference between file-based solution and data-based solution (Rillsoft Project with interface to Rillsoft
Integration Server).

File-based solution
Resource pool is a xml-file, it is located in the application folder.

For a networking or floating license would be right if this file indicates a network path such as \\Server_Name\Rillsoft
Project or a mapped folder e.g. R:\Rillsoft Project. A local path such as C:\Rillsoft Project would be wrong for a
floating license.

Change local folder to network folder (it is relevant only for floating license)
If your resource pool file indicates an incorrect (local) path, proceed as follows:

• Using Windows Explorer copy local Rillsoft folder, where is your resource pool file, to the Clipboard

• Then paste it into a network folder on the server

• Click File > Resource pool > File > Select
• In the dialog open select the inserted Rillsoft folder with resource pool file on the server

• Set a resource pool file from the Rillsoft folder on the server

• In the left corner of the status bar, check if your resource pool file uses the correct path.

Rillsoft Project offers a separate file repository, that is, program files are saved in the program folder and user files - in
the user folder. During installation all users will be granted full access to the user folder (data folder).

Users do not require a write access for the program folder.

Data-based solution (Rillsoft Project with interface to Rillsoft Integration Server)
Resource pool is saved in a central database.
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CHAPTER

FOUR

WORK WITH PROJECT

4.1 New Project

4.1.1 Create new project

In order to create a new project, do as follows:

1. Select the menu item File > New > New Project.

2. Select the menu item Start > Property > Project. The new project and the window Project properties appears.

3. Enter the project name in the field Name.

4. Enter the Start date and Finish date of the project in the tab General in the field Due date.

5. In the drop down list Project calendar, select the calendar you want to use for the project.

6. Click on the button OK.
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4.1.2 Open project

In order to open a project (also projects in XML format), do as follows:

• Select the menu item File > Open > File > Project. The dialogue Open appears.

• Select the preferred project file.

• Click on the button Open.

Note:
Projects of other formats, such as in XML format you can open by clicking File > Import.
Data-based solution (Rillsoft Project & Interface to Rillsoft Integration Server)

1. Select the menu item File > Open > Rillsoft Integration Server > Project. The dialogue Open appears.

2. Select the preferred project.

3. Click on the button OK.

4.1.3 New project from template

In order to work with templates, at first, you have to save a project by selecting the menu item File > Save as template.

In order to create a new project from a template, do as follows:

• Select the menu item File > New > New project from template or New project from Rillsoft Integration
Server template.

• Select the preferred project file in the appearing window.

• Click on the button Open or Ok.

• The dialogue Select activities from templates opens.
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• You can use the field Start to define the time the new project should start.

• You can use the field Finish to define the time the new project should finish.

• In the marked field Change in all activities, you can change either the Duration or Effort or Output of the
marked activities by the Proportionality factor.

• It lists all activities and subprojects from the template.

• Mark the activities and subprojects that you want to include in the project.

• Click on the button OK.

4.1.4 Reload project

If you are working in a multi-user environment, it may often be necessary to reload a project where several people are
working on different projects at the same time in order to view their changes.

With the help of the menu item File > Reload Project > Portfolio you can reload the current portfolio.

4.1. New Project 9
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Alternatively, you can use a quick access.

Click the Reload icon on the Quick Access Toolbar.

Notes: If the Reload icon is not present, you can select Reload from the Customise Quick Access Toolbar menu item.
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4.2 Set project properties

4.2.1 Define project properties

In order to define the project properties, do as follows:

Select the menu item Start >Properties >Project.

The window Object properties for the project opens below:

Enter the project name in the field Name.

Enter the project code in the field Code.

4.2. Set project properties 11
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Enter the fields Start date and Finish date of the project in the tab General in the area Due date.

In the field Cut off date, enter the date on which the project progress was last updated.

Note: The cut off date is meant to be entered for the controlling and management of ongoing projects. The cut off date
should be identical with the start date of the project to ensure correct scheduling.

In the drop down list Project calendar select the calendar you want to use for the project.

The button allows the quick access to the actual calendar.

In the drop down list Category select the category you want to use for the project.

Note: You can create a drop down menu for the category in the menu item Start > Properties > Resource > Project
categories.
In the field Priority enter a value between 1 and 1000. The higher the priority of a project is, the more resources can
be assigned to it during capacity alignment in relation to other projects in the project portfolio.

Note: Priority must not be 0.

In the drop down list Status select the status you want to use for the project.

Note: You can create a drop down menu for the status in the menu item Start > Properties > Resource > Project
status.
In the drop down list Baseline select the baseline you want to use for the variance analysis.

Note: This selection requires you, at first, to save a baseline via the menu item Project > Baseline > Add.

In the drop down list Time step select the interval for the automatic rounding of start and finish dates as well as duration.

In the drop down list Duration select the measurement unit you want to use for the duration measuring.

In the drop down list Effort select the measurement unit you want to use for the effort measuring. On workdays (depend
on calendar project) - workdays duration depends on the project calendar On workdays (8-hour workday) – a workday
is 8 hours. Choose from the drop down list effort measuring units to use in order to measure the effort. On workdays
(depend on calendar project) – a man day depends on the project calendar On workdays (8-hour workday) – a man day
is 8 hours.

Activate the check box Enter activity work results if you want to display the activity work results using the entering
of measurement units and quantities (such as 150 m3).

Activate the check box Enter activity effort if you want to display the activity effort using the entering of man-days (
such as 5 ED).

In the area Planning type you can define whether your project plan will be calculated capacity or due date oriented.

Activate the check box Capacity oriented, if the available resources are sufficient and should not be overloaded. It can
extend the activity duration and move tasks if assigned employees have nonworking days during the activity time.

Activate the check box Due date oriented, if you want to keep the activity and project due date in any case. If as-
signed employees have nonworking days during the activity time, negative effort is calculated for an activity that has a
difference between an effort that is assigned to roles and the effort that is covered by the employee with the requested
role.

In the drop down list Color select the color you want to use for the project/subproject bars.

Activate the check box Use the subordinated subprojects and activities if you want all the project / subproject related
activities to be displayed in the same color.

Click on the button OK.
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4.2.2 Preferred teams

You can use the tab Preferred teams to assign particular teams to the project. In calculating the project the capacity
planning for the personnel includes only employees that are members of the Preferred teams. You can also edit the
list Preferred teams later.

In order to define **Preferred teams, do as follows:**

• Activate the tab Preferred teams in the window Project
properties.

• Doubleclick on a team in the left table to define a preferred team.

• Click on the button OK.

4.2.3 Define machine types that can be shared

Machine types that can be shared can be used by predefined activities simultaneously without increasing the number
of machines.

The costs are not allocated to the individual activities; they are calculated as a whole and for each of the activity
separately.

Example 1 (shared machine types) Scaffolding is defined as a shared resource and will be used for several activities,
such as window installation or facade plaster. In case of time conflicts of the activities using this resource, the number
of the required scaffold is not added up, but remains constant on defined number level.

Example 2 (separately used machine types allocated to activities) A special drilling machine is allocated in the activity
properties as machine used for several activities. In case of a time conflict of the activities using this resource, the
number of the required machines will be added up.

In order to define shared machine types, do as follows:
• Activate the tab Machine types that can be shared in the window Project properties.

• Doubleclick on a machine type in the left table to define it as a shared machine type.
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• Enter the Number of the required machine types and their Load in the table to the right.

• Click on the button in the column Activities. The dialogue Activities using the same resources opens:

• Select from the activities list the ones that should share the machine type.

• Click on the button OK. The selected activities are entered in the column Activities.
• Click on the button OK.

Note:
• You can reduce the drop down list of machine types by entering a string value of the group name, the name or

code in the field Filter.
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The view Machine types (tab Project properties) shows each of the shared machine types separately. The table of the
selected, commonly usable machine types shows each of the shared machine types separately.

4.2.4 Define machinery that can be shared

Machinerythat can be shared can be used by predefined activities simultaneously without increasing the number of
machines.

The costs are not allocated to the individual activities; they are calculated as a whole and for each of the activity
separately.

Example 1 (shared machinery) Scaffolding is defined as a shared resource and will be used for several activities, such
as window installation or facade plaster. In case of time conflicts of the activities using this resource, the number of
the required scaffold is not added up, but remains constant on defined number level.

Example 2 (separately used machinery allocated to activities) A special drilling machine is allocated in the activity
properties as machine used for several activities. In case of a time conflict of the activities using this resource, the
number of the required machines will be added up.

In order to define a shared machine, do as follows:

• Activate the tab Machinery that can be shared in the window Project properties.

• Doubleclick on a machine in the left table to define it as a shared machine.

• Enter the Load of the required machines in the table to the right.

• Click on the button in the column Activities. The dialogue Activities using the same resources opens:
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• Select from the activities list the ones that should share the machines.

• The selected activities are entered in the column Activities.
• Click on the button OK.

Note:

• You can reduce the drop down list of machines by entering a string value of the group name, the name or code
in the field Filter.

The view Machinery (tab Project properties) shows each of the shared machines separately.

The table of the selected, commonly usable machinery shows each of the shared machines separately.
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4.2.5 Define header and footer

You can use the header and footer to define the print format of a project schedule. In this case, you do not have to set
the headers and footers for each of the pages separately, but all at once.

You can adjust titles (left-top, . . . right-bottom, see below) to your requirements.

In order to define the headers and footers of a project, do as follows:

• Activate the tab Headers and footers in the window Project properties.

• Click on one of the fields and enter your text or select a predefined field in the drop down list Fields.
• If necessary, repeat Step 2 for all the other fields.

• Click on the button OK.

Table fields:

View name Name of the view
Project name name of the project
Project start time Time of the project’s beginning
Project start date Date of the project’s beginning
Project ending time Time of the project’s ending
Project end date Date of the project’s ending
Project costs Total costs
Project effort Total effort
Project user defined fields Free defined fields for project information
Subproject name Name of the subproject
Subproject start time Time of subproject’s beginning
Subproject start date Date of subproject’s beginning
Subproject ending time Time of the subproject’s ending
Subroject end date Date of the subproject’s ending
Subproject costs Total costs
Subproject effort Total effort
Subproject user defined fields Free defined fields for subproject information
Cut-off date time Time of the project’s cut-off date
Cut-off date Date of the project’s cut-off
Last saving time Time of the last project’s saving
Last saving date Date of the last project’s saving
Printing time Time of the project’s printing
Printing date Date of the project’s printing

Note:
• You can print all the project views.
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• You can format the texts in the individual fields by means of the corresponding functions.

4.2.6 Define format

You can define the bar labelling and colour for activities and subprojects at your convenience.

In order to define the format, do as follows:

• Activate the tab Format in the window Project properties.

You can use the area Bar labelling to define the bar labelling of activities and subprojects.

• The Type column shows which object – an activity or a subproject - is labelled.

• The Position column indicates the labelling position.

• The Content column indicates the selected labelling.

• Set the cursor on the area Bar labelling according to the required position in the corresponding row.

• Then switch to area Fields and choose a variable that should be integrated into the labelling.

• By double-clicking it will be copied in the field Bar labelling.

• Finally, click on the button OK.

4.2.7 Define color

You can define the bar color for the activities and subprojects at your convenience.

To define the color depending on resources:

1. Activate the Color in the project properties window.

2. If you click the right mouse button on the table area, you can define which columns appear in the table.
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3. The column Type indicates whether there is a role, team, employee, or machine.

4. The column Name includes resources that are planned in the project/portfolio.

5. After clicking the left mouse button on the preferred row of column Color and pressing the button with three
dots, you can set color for activities, where the resource, such as Project management, is planned.

6. If, for example, two different colours of an activity are associated with defined resources, the activity is repre-
sented by the resource color, which is on a higher position in the list.

7. Restore - delete all of the dependency rules.

8. Set automatically -distribute resources colors automatically.

9. Up – increase the resource priority in the color allocation.

10. Down – reduce the resource priority of in the color allocation.

11. Click on the button OK.

4.2.8 Create user-defined fields

You can view user-defined fields in the tables or print them.

In order to create an user-defined field, do as follows:

• Activate the tab User-defined fields in the window Project
properties.
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• Enter the field name in the Name column.

• Enter your information in the Text column.

• Click on the button OK.

Use formula
You can enter the project variable in user field and use formula.

Enter a formula in the project properties window in the tab User fields in the column Text.
In the formula you can use almost all the fields from the register Format.
Following basic operations +, -, x, / are available.

4.2.9 Enter notes & links

You can use this tab to enter your own notes and assign external links to the project / subproject or link the project /
subproject to document or graphic files. You can use the following key words for links:

• http:// for hyperlinks

• https://

• mailto:

• ftp://

• news:

• telnet:
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• file: for document and graphic files

You may proceed as follows:
• Activate the tab Notes in the window Project/subproject properties

• Enter the text of your notes.

• If you click the Add hyperlink to external document button, you can create a reference to an internal file.

• If you click the Add hyperlink to external folder button, you can create a reference to an internal folder.

• To add a reference to external website, enter the required Internet address such as: http://www.rillsoft.de/

• Click on the button OK.

Alternatively: If you rightclick on the tab field in Notes, you can select one of the following commands in the context
menu.

4.2.10 Documents(DMS)

DMS (Document Management System) is only available in the database-based solution Rillsoft Project with Rillsoft
Integration Server.

Click on Start > Properties > Project.

At the bottom of the Properties window, select the tab Documents.
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On this tab you will see information divided into two sections.

The left pane shows a document-directory structure. Next to a directory name is the number of added documents.

When you click on a directory name, you will get a directory content with brief information in the right area.

You can edit documents by corresponding button:

• Add

• Delete

• Download

• Update

Drog & Drap You can use this function here by dragging selected documents into the right area with the left mouse
button pressed down. For example, email messages directly from Outlook to Rillsoft Project DMS.

Documnets manage in project or portfolio
All documents assigned to a project or portfolio can be managed in the dialog Rillsoft Integration Server Document.
Click on Project > Rillsoft Integration Server > Project documents.

Here you can also filter out any documents.
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Folder structure
You can define a folder structure in Rillsoft Integration Server.

4.3 Settings for project and programme

4.3.1 Save settings in the workplace

The following settings can be saved in the workplace and used thereafter as default settings for other projects.

• Project properties as units of duration and effort etc.

• Arrangement of columns in tables

• Time scale representation

First you can adjust them according to your needs and then save by clicking on Project > Project settings > Save in
the workplace.
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4.3.2 Copy settings from the workplace

If you have previously set the settings and saved them in the workplace, you can take them for an open project by
clicking on Project > Project settings > Copy from the workplace.

The following settings can be saved in the workplace and used thereafter as default settings for other projects.

• Project properties as units of duration and effort etc.

• Arrangement of columns in tables

• Time scale representation

You can set project properties in the object properties window.

4.4 Settings for project with Rillsoft Integration Server

4.4.1 Save settings for project

This function is offered only in the Rillsoft with interface to Rillsoft Integration Server Solution.

The option is active, if settings are set either per client or per user of client in the client properties.
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In order to save the settings for a project, please click on Project > Rillsoft Integration Server > Save settings.

The following settings can be used as default settings for other projects.

• Project properties as units of duration and effort etc.

• Arrangement of columns in tables

• Time scale representation

You can set project properties in the object properties window.
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4.4.2 Save settings for header and footer

This function is offered only in the Rillsoft with interface to Rillsoft Integration Server Solution.

The option is active, if settings for header and footer are set either per client or per user of client in the client properties.

In order to save the settings for header and footer, please click Project > Rillsoft Integration Server > Save headers
and footers.
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You can set headers and footers rows in the object properties window in the folder Headers and footers.

4.4.3 Save settings for user view

This function is offered only in the Rillsoft with interface to Rillsoft Integration Server Solution.

The option is active, if settings for user view are set either per client or per user of client in the client properties.

In order to save the settings for user view and to use them therefore as default views for other projects, please click on
Project > Rillsoft Integration Server > Save user view.

You can save user view by using the command Start > user views > Save.
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4.4.4 Project documents

This feature is only offered in the Rillsoft solution with interface to Rillsoft Integration Server.

To open the project documents of a project, please click Project > Rillsoft integration server > Project documents.

The dialog box Rillsoft integration server document opens.

The following activities are available:

• Add add a document directly to the project

• Delete delete a selected document from the project

• Download save a selected document as a separate file

• Update update a selected document

You can set project properties in the properties window.
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4.5 Project information

4.5.1 Project information

Click on Start > Properties > Info to display project information.

Alternatively you can

1. click with the left mouse button on a free space in the Gantt chart or one of the other views. The window with
information appears at the bottom of the program window.

2. Select one of the tabs.

4.5.2 Late activities

Click on Start > Properties > Info to display late activities.

Select the tab Late activities.
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Late activities indicate that a project plan has not been updated by a completed percentage, but a deadline has been
postponed.

You can find the following information about late activities in the window:

Conflict shows a difference between the timepoint of an activity, where the activity is not yet completed, and the
deadline in working days.

Nr. - activity number

Name - activity name

Effort - general activity effort for all assigned resources

Negative Effort - shows the difference between an effort assigned to roles and the effort covered by employees. As an
example. If a role with 24 Ph (3 AT) is first assigned to an activity and then to an employee who can fulfil this role.
However, the employee has a nonworking day over the activity time and can fulfil only 16 Ph (2 AT). The negative
effort is 24 - 16 = 8 Ph.

Duration - activity duration

Start - start of activity

Finish - end of activity

Balance employee - contains the dynamically calculated difference between the requested effort for a role and the
summarized effort of the already assigned employees with the same role and qualification. This serves as support
during the controlling of the required assignations of employees. A negative value, for instance, indicates that more
employees with this role and qualification are required.

Balance machine - contains as a dynamic calculation the difference between the requested effort for the machine type
and the summed effort of the already assigned machines of the same machine type. This serves as a support for checking
the necessary machine assignments. A negative value shows you, for example, that more machines of this machine type
are needed.

4.5.3 Overallocated resources

Click on Start > Properties > Info to get a quick overview of activities with overallocated resources

Select the tab Overallocated resources.
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Note Only one conflict is listed for each activity. You can get detailed information about overallocated resources either
on the resources view Employee or on the tab Employee in the properties window of an activity.

In the window Overallocated resources you can find the following information:

Conflict displays an overloaded employee, the number of days of overload, and its overallocation in percentage within
activity duration.

Nr. - activity number

Name - activity name

Effort - general activity effort for all assigned resources

Negative Effort - shows the difference between an effort assigned to roles and the effort covered by employees. As an
example. If a role with 24 Ph (3 AT) is first assigned to an activity and then to an employee who can fulfil this role.
However, the employee has a nonworking day over the activity time and can fulfil only 16 Ph (2 AT). The negative
effort is 24 - 16 = 8 Ph.

Duration - activity duration

Start - start of activity

Finish - end of activity

Balance - contains the dynamically calculated difference between the requested effort for a role and the summarized
effort of the already assigned employees with the same role and qualification. This serves as support during the con-
trolling of the required assignations of employees. A negative value, for instance, indicates that more employees with
this role and qualification are required.

4.5.4 Failed resource

Click on Start > Properties > Info to display failed resources

Select the tab Failed resource.
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In the window you can find general information about failed resources.

Note If there are multiple conflicts in the activity due to a resource failure, only one conflict is listed. For detailed
information see Activity Properties on the tab Personal in the column Negative Effort.

Conflict shows the number of employees who have failed because of the nonworking days, the number of their non-
working days, and their absence in percentages within activity duration.

Nr. - activity number

Name - activity name

Effort - general activity effort for all assigned resources

Negative Effort - shows the difference between an effort assigned to roles and the effort covered by employees. As an
example. If a role with 24 Ph (3 AT) is first assigned to an activity and then to an employee who can fulfil this role.
However, the employee has a nonworking day over the activity time and can fulfil only 16 Ph (2 AT). The negative
effort is 24 - 16 = 8 Ph.

Duration - activity duration

Start - start of activity

Finish - end of activity

Balance - contains the dynamically calculated difference between the requested effort for a role and the summarized
effort of the already assigned employees with the same role and qualification. This serves as support during the con-
trolling of the required assignations of employees. A negative value, for instance, indicates that more employees with
this role and qualification are required.

Note Failed Resources can only be seen in a Due date oriented.
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4.5.5 Unassigned resources

Click on Start > Properties > Info to get a quick overview of activities with unassigned resources

Select the tab Unassigned resources.

In the window Unassigned resources you can find the following information:

Conflikt shows a role effort that has not yet been covered with employees and the assigned role for this effort.

Nr. - activity number

Name - activity name

Effort - general activity effort for all assigned resources

Negativ Effort - shows the difference between an effort assigned to roles and the effort covered by employees. As an
example. If a role with 24 Ph (3 AT) is first assigned to an activity and then to an employee who can fulfil this role.
However, the employee has a nonworking day over the activity time and can fulfil only 16 Ph (2 AT). The negative
effort is 24 - 16 = 8 Ph.

Duration - activity duration

Start - start of activity

Finish - end of activity

Balance - contains the dynamically calculated difference between the requested effort for a role and the summarized
effort of the already assigned employees with the same role and qualification. This serves as support during the con-
trolling of the required assignations of employees. A negative value, for instance, indicates that more employees with
this role and qualification are required.
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4.5.6 Partially assigned resources

Click on Start > Properties > Info to display partially assigned resources

Select the tab Partially assigned resources.

The warning about Partially assigned resources comes only if two situations occur together:

• firstly, if mixed resources have been assigned to a task, such as roles and employees

• secondly, if the role effort planned in the process was not completely covered but partly covered with employees

In this case, a conflict arises because an employee assignment has a higher priority in Rillsoft Project. That when
calculating the effort of the activity, only one employee expense is included in the calculation, and the role effort is not
taken into account.

Tip! It is better to either assign only the roles to an activity or cover the role requirements required by the activity
completely with responsible employees.

The following information about conflict because of inconsistent resources can be found in the window:

Conflikt shows the role assigned to a task that did not have employee coverage while concrete persons were already
assigned to this task.

Nr. - activity number

Name - activity name

Effort - general activity effort for all assigned resources

Negativ Effort - shows the difference between an effort assigned to roles and the effort covered by employees. As an
example. If a role with 24 Ph (3 AT) is first assigned to an activity and then to an employee who can fulfil this role.
However, the employee has a nonworking day over the activity time and can fulfil only 16 Ph (2 AT). The negative
effort is 24 - 16 = 8 Ph.

Duration - activity duration

Start - start of activity

Finish - end of activity

Balance Employee - contains the dynamically calculated difference between the requested effort for a role and the
summarized effort of the already assigned employees with the same role and qualification. This serves as support
during the controlling of the required assignations of employees. A egative value, for instance, indicates that more
employees with this role and qualification are required.
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Balance Machinery - contains the dynamically calculated difference between the requested effort for a machine types
and the summarized effort of the already assigned machinery with the same machine types. This serves as support
during the controlling of the required assignations of machineries. A egative value, for instance, indicates that more
machinery with this machine types are required

Sample of calculation for partially assigned resources.

The activity A are assigned to two roles, programmer C++ and designer, each 8 people hours. Thus, the effort at the
role level is calculated as follows 8 + 8 = 16 people hours. In the next step, the employee Mr Tidy is assigned to this
activity A as a programmer C++, he takes over the programmer C++ effort in the amount of 8 persons hours. The role
of designer, however, remains without cover by a concrete employee. As a result, the total effort at the employee level
is estimated to be only 8 people hours. Although the role designer at the resource view roles is listed but without effort.

4.5.7 Project overview

Click on Start > Properties > Info to display failed resources.

Select the tab Project overview
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You see all the general information about the Project in the appearing window.

4.5.8 Portfolio dashboard

The portfolio overview shows projects that have been last opened in the portfolio.

Um sich Portfolio dashboard anzeigen zu lassen, klicken Sie bitte Start > Eigenschaften > Info

Select the tab Project dashboard

You can use the button to select a portfolio.

The portfolio’s projects marked with a check mark are considered in the calculation of the resources availability.

4.5.9 Cross-project links

Cross-project links are only available in Rillsoft Project with Rillsoft Integration Server (RIS).

To display cross-project links, please click Start > Properties > Info.

Select the Cross-project Links tab.

Note: The tab Cross-Project Links is only visible with the database-based solution Rillsoft Project with RIS.
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All cross-project links in the portfolio/collective project are listed here.

• The column Predecessor project/activity shows the activities from which a link originates.

• The Successor project/activity column shows the activities that are at the end of the link.

• The columns Start and Finish allow you to follow a beginning and an end of a link.

• Reserve informs you whether there is a time gap in absolute time between the initial position and the input
position.

• Delay represents a value of the time gap released from the beginning.

•

4.5.10 External documents

To display external documents, please click Start > Properties > Info.

Select the External Documents tab.

Note: The **External Documents tab is only visible with the file-based solution Rillsoft Project.

All references in the project/sub-project are listed here.

• The names of the tasks or sub-projects are shown in the Name column. are shown.

• Double-clicking on the Name takes you to the Notes tab in the task properties.

• The names of the linked files are shown in the External Link column. are displayed. If you double-click on the
link, this file is opened.
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4.6 Create activities

4.6.1 Create activities

In order to create a new activity, do as follows:

1. click on the menu Start > Activity.

1. Enter an activity name in the appropriate row.

In order to create a new activity in any position, do as follows:

Alternative 1: Set the cursor on the position you want in the Gantt chart and pressing the mouse button draw a bar.
This way the start date and finish date as well as activity duration will be defined at the same time.

Alternative 2: You can create an activity via the diagram field of the context menu.

In order to create a new activity in any position, do as follows:

• Rightclick on the space in the Gantt chart where you want to create a new activity. It can also be between other
activities.

• Choose the item New activity in the context menu .
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4.6.2 Edit activities

In order to edit any parameter of an existing activity, do as follows:

• In the diagram click on the activity whose parameter you want to
edit.

• Activate the required tab in the window Properties and make the
changes.

• Click on the button OK.

Edit in the Activity table
You may make the changes to the most important activity parameter directly in the table of the Gantt chart.
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Edit in the Gantt chart area
You may use the mouse to shift the activity in the diagram, so as to change its time parameters or duration.

Edit schedule
You can quickly check the completion percentage if you select the menu item Start > Schedule.
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4.6.3 Delete activities

In order to delete an existing activity, do as follows:

• Rightclick on the activity you want to delete.

• Choose the menu item Start > Edit > Delete.

Alternatively: You can quickly delete an existing activity by clicking on the blank space in the diagram with the right
mouse button pressed down and striking out the activity.

4.7 Working with activity and subproject tables

The Activity and Subproject tables display the most important parameters. You can adjust the tables to you requirements
doing the following:

1. click on the menu Format > Columns

Alternative
1. rightclick on the column names of the table and choose Properties in the context menu.

1. In the appearing window you can edit the column layout and choose which of the columns (also user-defined
fields) you want to have on display.
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Change the width of the table
• change the width of a column and so affect the overall width of the table.

• temporarily collapse and unfold a table via the button.

Navigation
• You can use the arrow buttons upwards and downwards to toggle between activities and subprojects. You can

use the buttons Tab and Shift+Tab to jump forwards and backwards among the single columns.

Unit of measurement
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is in Project / Project Properties / General / Project Settings by specifying the duration and effort for tasks in hours
or define in working days, weeks, etc.

Fields in the table

No. Number of WBS code
Info Signals whether it has been referred to internal documents or external links from an activity / subproject
Warning Alert about overallocated, failed resources, or late activities
Name Name of activity or subproject
Code Code of activity or subproject
Category Project category
Priority Project priority
Status Project status
Quantity Quantity of the working results, measured by the measurement unit defined for the activity
Completed Completed quantity
Open Open quantity
Measurement unit Measurement unit for the activity’s working result (such as: m3, freight, . . . ) .
Norm Norm in man-hours required for the completion of a measurement unit within an activity
Effort Effort of the activity or subproject
Completed Completed effort
Open Open effort
Duration Duration of the activity or subproject
Completed Completed duration
Open Open duration
Start Start time (date and time of day) of the activity or subproject
Start Start time (date) of the activity or subproject
Finish Finish time (date and time of day) of the activity or subproject
Finish Finish time (date) of the activity or subproject
Earliest possible start Earliest possible start of activity Caution! Will only be shown if the option Calculation of contingency reserve is activated in Tools / Global settings / General.
Start, reserve Contingency reserve (difference between start and earliest possible start). Caution! Will only be shown if the option Calculation of contingency reserve is activated in Tools / Global settings / General.
Latest possible finish Latest possible finish of activity Caution! Will only be shown if the option Calculation of contingency reserve is activated in Tools / Global settings / General.
Finish, reserve Contingency reserve (difference between latest possible finish and finish). Caution! Will only be shown if the option Calculation of contingency reserve is activated in Tools / Global settings / General.
Fixed costs Separate costs of the activity or subproject that are not shown by the view of resources
HR costs Costs for the activity or subproject’s personnel resources
Material costs Material costs for the activity or subproject
Machine costs Machine costs for the activity or subproject
Costs Total costs for the activity or subproject
Completed Percentage of completion of the activity / percentage of progress
Amount of invoice Amount for the invoicing period of the project
Payment period Period of time in working days for the due date of the payment
Receipt of payment Date of payment receipt
Predecessor “From” activities
Successor “To” activities
Roles Assigned roles
Teams Assigned teams
Employees Assigned employees
Material Allocated materials
Machine types Allocated machine types
Machinery Allocated machinery
Balance Difference between the demand for assigned roles and the demand for assigned employees (for a quick overview over missed assignations of employees in activities)
User-defined fields 1 - 20
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4.8 Link activities

4.8.1 Link activities

Activities can be linked with each other in Gantt chart, network charts and Gantt-network charts.

The following link types are at your disposal:

Finish-Start the “from” activity must finish before the “to” activity can start
Start-Start the “from” activity must start before the “to” activity can start
Finish-Finish the “from” activity must finish before the “to” activity can finish
Start-Finish the “from” activity must start before the “to” activity can finish
Incompatible activity group Activities that must not be executed at the same time (time conflicts)

You can unhide the Properties window of any link by doubleclicking on the link.

Time intervals
Intervals can be defined in Project properties in relation to the time unit of the duration (such as hours or days). You
can choose among the following types of intervals:

• in absolute time (1 day consists of 24 hours, that is, for example, 8 hours and 16 non-working hours)

• in calendar time (depending on the actual calendar, for example, 1 day consists of 8 hours, that is, it ignores
non-working hours)

• in relative time (for instance, a particular percentage, relating to the “to” activity, such as: 50%)

Intervals can have
• positive (such as: + 2 hours) or

• negative (such as: - 50% = overlapping)

signs.

Highlight link
Links can be highlighted by means of colour or boldface.

Create link
In order to create a new link, do as follows:

• Choose the link type via the menu Start > Insert > Link.
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• Connect two activities by drawing your mouse from one activity to another.

• Choose the interval type for the link in the Properties window.

• If necessary, enter the Delay (positive or negative) by which you want to delay the “to” activity depending on the
selected type of link.

• Click on the button OK.

Alternatively: You can create link activities in the diagrams via the context menu.
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Context menu:
If you want to move a chain of activities backwards or also forwards with respect to a specific activitiy, two following
commands are available from the context menu:

• Previous activity customize the latest start time

• Successor activity customize the earliest start time

Notes (restrictions in the links creation):
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• The occurrence of an activity is only allowed in incompatible activity groups.

4.8.2 Edit link

Links can only be edited as long as the succeeding activity has not yet started.

In order to change an existing link, do as follows:

• Mark the link you want to edit by clicking on the line connecting the
two activities.

• From the drop down menu Link type select another link type in
the properties window.

• If necessary, enter the Delay (positive or negative) by which you
want to delay the succeeding activity depending on the selected activity type.

• Click on the button OK.

Alternatively: You can change the Link type via the context menu of the connecting line.

4.8.3 Delete link

You can quickly delete an existing link by clicking on the blank space in the diagram with the right mouse button
pressed down and strike out the link.

Alternatively: In order to delete an existing link, do as follows:

• Rightclick on the activity.

• From the context menu, choose the command Incoming link delete / Outbound link delete.

• Choose the link you want to delete.
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4.9 Activities properties

4.9.1 Enter activity properties

In order to define the properties of an activity, do as follows:

• Mark the activity whose properties you want to enter.
The window Object properties opens.

1. Enter the activity name in the field Name.

2. Enter the activity code in the field Code.

The following three fields will be available only if you have marked the check box Enter deliverable for activity in
the menu item Start > Properties > Project in Project properties.
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3. If necessary, enter the labour quantity as measured in the predefined measurement unit.

4. If necessary, enter the measurement unit of the labour amount (such as m3, load,. . . ).

5. If necessary, enter the norm in man-hours required for the completion of a measurement unit.

The following three fields will only be available, if you have marked the check box Enter effort for activity in the
menu item Start > Properties > Project in Project properties.

6. Fixed duration - Choose this option to calculate the effort for the activity and the resource utilization, with the
duration of the activity remaining unchanged, if possible. You should choose this option if you do the scheduling
on the basis of the known activity duration. The labour effort of the resources would then be automatically
calculated.

7. Fixed effort - Choose this option to calculate the activity duration and the resource utilization, with the effort
remaining unchanged. You should choose this option if you do the scheduling on the basis of the known activity
efforts for activity roles. The activity duration would then be automatically calculated.

8. Fixed effort & duration - Choose this option to calculate the quantity and resource utilization on the basis of
the constant effort and constant duration. This option allows you to calculate the quantity and utilization of the
required personnel resources.

Note: This option is only suitable for role assignation.

9. Enter the activity effort in the field Effort.
10. Enter the activity duration in the field Duration.

11. Click on the button OK.
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4.9.2 Define general activity properties

In order to define the general properties of an activity, do as follows:

• Activate the tab General in the window Activity properties.

Field Due date
• Choose the option Start if you have a fixed start date of the activity and enter Date and Time. The finish date

of the activity will be calculated automatically.

• Choose the option Finish if you have a fixed finish date of the activity and enter Date and Time. The start date
of the activity will be calculated automatically. Note: You can move the start date and finish date of an activity
much more quickly in the diagram by using the mouse to shift the activity.

• Mark the check box Fix if the activity due dates in the optional date calculations that have been selected via the
menu must not be shifted.

• Mark the check box Mark as milestone if you want to label the activity as milestone. In this case, activity
duration is set to zero. Field Activity calendar

• Select the calendar you want to use from the drop down list Activity calendar.

The button allows for the quick access to the actual calendar.

• Mark the check box Disregard team calendar and employee calendar if the team calendar and employee
calendar should not be regarded in new activities.

• Mark the check box Start of activity only at first shift if the start of activity is permitted to begin only at the
first shift.

• Mark the check box Merge into one line if you want to have several activities succeeding in a row displayed
hierarchically independent.

• Enter the percentage of completion of an activity in the field Completed.

• Enter extra costs that are not on display along with the resources in the field Fixed costs.
Field Financing

• Enter the amount of the payment period in the field Invoice amount.
• Define a period of time in business days for the due date of the payment in the field Term of payment.
• You can enter the date of the payment receipt in the field Receipt of payment only if you have declared the

milestone to be 100% completed. Once you have marked the milestone as 100% completed, the payment receipt
is displayed automatically along with the due date of the milestone plus the term of payment. You may also
correct the date.

• Select the color you want to use from the drop down list Color
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• Click on the button OK.

4.9.3 Assign roles

In order to assign roles to the selected activity, do as follows:

• Activate the tab Roles in the window Activity properties.

Available roles
• Enter a string value in the field Filter to show only certain roles (search via role group and code) or enter two

dots “..” in order to view the roles that have already been used in the project.

• Doubleclick on the entry in the left table to assign the role to the activity. Assigned roles
• Enter a differing value for the number of employees required for this role in the field Quantity.

• Enter a differing value of the percentage the role is utilized in the activity in the field Utilization.

• Enter a differing value in the field Effort, for the effort that a role has to perform within the activity.

• Enter notes that might be crucial for the role in connection with the activity in the the field Notes.
• Click on the button OK.

Notes:
• You can adjust the columns layout of both tables at your convenience by rightclicking on the column names of

the table and selecting the columns you want to adjust.

• You can use the menu item Project / Roles from Employee assignation to define roles within a project for available
employees who are required for the activity completion. This allows you to use easily these settings as templates
for other activities.

• In order to have quick access to the used resources, click on the button Resource pool if you are using the general
resource pool - or on the button Project resources if you are using a project-specific resource pool.
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4.9.4 Assign employees

In order to assign employees to the selected activities, do as follows:

• Activate the tab Employees in the window Activity properties.

Assigned roles
• Mark the check box of a role in the list Assigned roles in order to use this role as additional filter for the employees

list. The list of employees shows you only those employees who have the appropriate roles and qualifications.

• The column Quantity-workload-effort contains the required number of employees whose workload and effort
meet the demands of the role. This column is deactivated by default. If you want to unhide it, please refer to
Details.

• The field Balance contains the dynamically calculated difference between the requested effort for a role and the
summarized effort of the already assigned employees with the same role and qualification. This serves as support
during the controlling of the required assignations of employees. A negative value, for instance, indicates that
more employees with this role and qualification are required.

Preferred teams
• Mark the check box Preferred and assigned teams to use the assigned teams as an additional filter for the em-

ployees list. The list of employees will show you then only those employees that belong to assigned teams.

Available employees - The table in the centre lists, depending on the filter settings (teams, roles, and entries in the field
filter), all employees defined in the resource pool and available for being assigned to actual activities.

• Enter a string value in the field Filter to show only certain employees (search via employee name and code) or
enter two dots “..” in order to view the employees that have already been used in the project.

• On-call - percentage of the possible working capacity of an employee within activity duration, adjusted for the
reported non-working days (holidays/sickness).

• Availability - percentage of the possible working capacity of an employee within activity duration, adjusted for
the participation of the employee in other activities of the project.
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• To include the workload in other projects that belong to a selected portfolio during scheduling, open the desired
portfolio:

• Click on Start > Properties > Info

• Select the tab Portfolio dashboard.

• Doubleclick on the entry in the central table to assign this employee to the activity.

Assigned employees
• On-call - percentage of the possible working capacity of an employee within activity duration, adjusted for the

reported non-working days (holidays/sickness).

• Availability - percentage of the possible working capacity of an employee within activity duration, adjusted for
the participation of the employee in other activities of the project as well as their workload in this activity.

• Enter a differing value in percent in the field Productivity if the productivity of the employee in the activity
differs (they are proposed from the resource pool).

• Enter a differing value in percent in the field Workload if the employees workload in the activity differs. If
you have reported a role usage to the tab Roles, this workload will be taken over; otherwise, default workload is
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100%.

• If you click on the icon in the field Absence, the window Absence with the calendar field opens where you can
define the days the employee will not be participating in the activity.

• Enter a differing value in the field Effort for the effort that an employee has to perform within the activity.

• Select the check box Responsible, if the employee is to be registered as the person responsible for the activity.

• Enter notes that might be crucial for the employee in connection with the activity in the the field Notes.
• Mark the check box Utilize resources to the maximum in order to obtain the shortest possible activity duration.

This redistributes the effort of the resources with identical qualifications in a way to allow for a better resource
utilization, which can affect the activity duration by, for instance, a higher percentage of readiness.

• Click on the button OK.

Notes:
• You can adjust the layout of the columns of the three tables at your convenience by rightclicking on the column

names of the table and selecting the columns you want to adjust.

• In order to have quick access to the used resources, click on the button Resource pool if you are using the general
resource pool - or on the button Project resources if you are using a project-specific resource pool.
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4.9.5 Timesheet

Here you can display information about completed working hours in the activity.

Requirement You can only enter timesheet in the Rillsoft Integration Server interface.

In order to assign timesheet to the selected activities, do as follows:

• Activate the tab Timesheet in the window Activity properties.

Employees
All employees assigned to the task are listed here.

Name Name of assigned employee

Effort shows the effort planned in the activity for this employee

Close how much of the planned effort the employee has already done for the activity

Open shows still open effort in the activity for this employee

Notes Notes

Timesheet
Here you can see for an employee selected in the left table, how did he complete the task day by day.

Week in which calendar week did the employee work for the activity

Weekday on which day of the week the employee worked for the activity

Date Date

Effort shows the effort planned for this employee during the day and for the activity

Close shows how much of the planned effort the employee has already done on the day

Schicht daytime

4.9.6 Allocate material

In order to allocate material to the selected activities, do as follows:

• Activate the tab Material in the window Activity properties.
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Available Material
• Enter a string value in the field Filter to show only certain materials (search via material group, material type

and code) or enter two dots “..” in order to view the materials that have already been used in the project.

• Doubleclick on the entry in the left table to assign the material to the activity.

Allocated material
• Select calculation the type of material requirements in the field Calculation: Fixed - The material requirements

in the activity are fixed. Per hour - The material requirements in the activity are calculated by considering the
activity duration. Per man-hour - The material requirements in the activity are calculated by considering the
effort. Per quantity - The material requirements in the activity are calculated by considering the working result.

• Enter a differing value of the material quantity, which is required for the activity, in the field Quantity.

• Enter notes that might be crucial for the material in connection with the activity in the the field Notes.
• Click on the button OK.

Notes:
• You can adjust the layout of the columns of both tables at your convenience by rightclicking on the column names

of the table and selecting the columns you want to adjust.

• In order to have quick access to the used resources, click on the button Resource pool if you are using the general
resource pool - or on the button Project resources if you are using a project-specific resource pool.
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4.9.7 Allocate machine types

In order to allocate machine types to the selected activities, do as follows:

• Activate the tab Machine types in the window Activity properties.

Available machine types The left table shows you all the machine types defined in the basic resources.

• Enter a string value in the field Filter to show only certain machines (search via the machine group, type and
code) or enter two dots “..” in order to view the machine types that have already been used in the project.

• Doubleclick on the entry in the left table to allocate this machine type to the activity. Allocated machine types
The right table shows you the machine types already selected for the activity.

• Enter the number of machine types required for this activity in the field Number.

• Enter the machine type usage of this activity in the field Usage.

• Enter notes that might be crucial for the machine types in connection with the activity in the the field Notes.
• Click on the button OK.

Notes:
• You can adjust the layout of the columns of both tables at your convenience by rightclicking on the column names

of the table and selecting the columns you want to adjust.
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• In order to have quick access to the used resources, click on the button Resource pool if you are using the general
resource pool - or on the button Project resources if you are using a project-specific resource pool.

• The time of use will be calculated automatically.

4.9.8 Allocate machinery

In order to allocate machines to the selected activities, do as follows:

• Activate the tab Machinery in the window Activity properties.

Allocated machine groups - machine types This table lists the allocated machine types in order to support you in
selecting the machinery.

• The marked check box of a machine group / machine type is an additional filter for the machinery list. The list
Machinery shows you only those machines that have the corresponding machine group and machine type.

• The field Quantity-utilization contains the required number of machines as well as their utilization for the machine
type. This column is deactivated by default. If you want to unhide it, please refer to Details.

• The field Balance contains the dynamically calculated difference between the requested number for a machine
type and the total number of the already assigned machines with the same machine type. Support in the control-
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ling of the required machinery allocations. A negative value, for instance, indicates that more machines of this
machine group and machine type are required.

Mark the check box Preferred and assigned teams to use the assigned teams as an additional filter for the list Ma-
chinery. The list Machinery will show you then only those machines that belong to the assigned teams.

Available machinery Depending on the filter settings (teams, machine type and the entries in the field Filter), the
central table shows you the machinery as defined in the basic resources. Enter a string value in the field Filter to show
only certain machines (search via the machine group, type and code) or enter two dots “..” in order to view the machines
that have already been used in the project.

• The field Availability shows the percentage of the possible working capacity of a machine within activity duration,
adjusted for the participation of the machine in other project activities.

• Um bei der Einplanung die Maschinen-Auslastung in anderen Projekten, die zu einem ausgewählten Portfolio
zugehören, zu berücksichtigen, öffnen Sie das gewünschte Portfolio:

• Klicken Sie Start > Eigenschaften > Info

• Select the tab Portfolio dashboard.

• Doubleclick on the entry in the central table to allocate this machine to the activity.

Allocated machines
The right table shows you the machines already selected for the activity.

• Enter the machine usage of this activity in the field Usage.

• Enter notes that might be crucial for the machine in connection with the activity in the the field Notes.
• Click on the button OK.
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Notes:
• You can adjust the columns layout of the three tables at your convenience by rightclicking on the column names

of the table and selecting the columns you want to adjust.

• In order to have quick access to the used resources, click on the button Resource pool if you are using the general
resource pool - or on the button Project resources if you are using a project-specific resource pool.

• The time of use will be calculated automatically.

4.9.9 Check links

In order to check links, activate the tab Links in the window Activity properties.

“From” activity - The left table shows you all link types of the “from” activities along with the corresponding number
and description of the activity.

“To” activity - The table in the centre shows you all link types of the “to” activities.

Incompatible activities – The right table shows you all incompatible activities.
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4.9.10 Define format

You can define the bar labelling and colour for activities and subprojects at your convenience.

In order to define the format, do as follows:

• Activate the tab Format in the window Activity properties.

• Select the variables you want to integrate into the labelling from
the list Fields.

You can use the field Bar labelling to define the bar labelling of activities and subprojects.

• The field Type shows which of the objects - activities or
subprojects - will be labelled.

• The field Position shows the position of the labelling.

• The field Content shows the content of the labelling. Depending
on the preferred position, set the cursor on the corresponding content field.

• Enter either the labelling or select a predefined field from the drop
down list Fields and doubleclick.

• Click on the button OK.

Notes
If several activities are shown in a row, the internal activities can be labelled just below.
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4.9.11 Fill in user-defined fields

In order to fill in user-defined fields, do as follows:

• Activate the tab User-defined fields in the window Activity properties.

• Enter the text of your choice.

• Click on the button OK.

Note:
• First you need to define the Name of the user-defined fields in Project properties.
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4.9.12 Enter notes & links

You can use this tab to enter notes, attach links to the activity and link the activity with document and graphic files.
You can use the following key words for links:

• http:// for hyperlinks

• https://

• mailto:

• ftp://

• news:

• telnet:

• file: for document and graphic files

You may proceed as follows:

• Activate the tab Notes & links in the window Activity properties.

• Enter the text of your notes.

• If you click the button Insert Hyperlink to external document, you can create a reference to an internal file.

• If you click the button Insert Hyperlink to external folder, you can create a reference to an internal folder.

• To insert a reference to external website, enter the preferred Internet address such as http://www.rillsoft.de/

• Click on the button OK.

Alternatively: If you rightclick on the tab field in Notes & links-tab field, you can select one of the following com-
mands in the context menu.
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4.9.13 Assign documents in the DMS

Documents in the DMS (Document Management System) can be assigned only in the database-based solution Rillsoft
Project with Rillsoft Integration Server.

To assign documents to a selected activity, please proceed as follows:

Activate the Documents tab in the activity properties window

The Insert button allows you to add a new document to an activity.

If you have already marked a document, you can delete, download and update.

On this tab you can see information divided into two areas.

A document directory structure is shown on the left. The number of documents added is shown in brackets next to a
directory name.

When you click on a directory name, you will see a directory content with brief information in the right area.

You can edit documents using the corresponding button:

• Add
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• Delete

• Download

• Update

Drog & Drap You can use this function by dragging selected documents with the left mouse button pressed into the
right area.

Manage documents in the project or portfolio
You can manage all documents assigned to a project or portfolio in the Rillsoft Integration Server Document dialog.

Click Project> Rillsoft Integration Server> Project Documents.

Here you can also filter out any documents.
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4.10 Split activities

In order to split an existing activity, do as follows:

• Click Start> Schedule> . . . and one of the split-functions.

Alternatively: This function is availible via the context menu of the activity.

Rightclick on the activity in the diagram field.

66 Chapter 4. Work with Project



Rillsoft Project, Release 9

Select the command Split from the context menu and choose one of the following functions:

• into several activities

• from the completed part

• at the first shift

• in case of several assignments

Split into several activities
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Define the activity parameter according to which you want to split the activities in the field Split into. You can choose
between the following parameters

• Percentage,

• Deliverable,

• Effort,

• Duration,

• Costs

The values to be entered in the next field need to be separated by blank spaces.

Mark the check box Create finish-start links between activities if you want to link the split activities with each other.
Mark the check box Show in one row if you want to have the split activities displayed in one row. The list shows the
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split activities.

Split from the completed part
This command is activated if a part of an activity has been completed. In this case, the split date will be shown in
brackets. An activity is split into two activities, the first is 100% completed, the second has not yet started.

Split at the first shift
You can choose among the various due dates in the list, which mark the start of the next shifts.

Split in case of several assignments
This function is activated if two or more activities are executed at a time and more than one of these activities has been
assigned to the same resource. In order to avoid several assigments of one resource, you can split one activity before
the start of the other activity. You will find the program which offers you automatically the possible dates.

4.11 Split activities into places / subproject

In order to split activities into places / subproject, do as follows:

• Select the menu item Project > Assistant > Split activities into places / spaces.

• Enter the places / spaces you want to display later as spacess into this list.

You can use these places / spaces to also split activities in the next step.
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• Select the activity parameter according to which you want to split activities from the drop down list Divide by.
You can choose between the following parameters

• Percentage,

• Deliverable,

• Effort,

• Duration,

• Costs

The following activity list shows all activities which can be split into the places / spaces by entering them in the column
below the corresponding place / spaces.

Display of the project schedule before the splitting into places / spaces.
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Display of the project schedule after the splitting into places / spaces.
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4.12 Subprojects

4.12.1 Create subproject

You can create:

• a new subproject

• subproject from file

• subproject from Rillsoft Integration Server template

In order to create a new subproject in the table, do as follows:
1. Select the menu item Start > Insert > Subproject.

2. Enter a subproject’s name for in the appropriate row.

Create a new subproject in any area in the Gantt chart
1. Set the cursor on any area of the Gantt chart, where you want to create a blank Project.

2. Click with the right mouse button and select from the context menu New Subproject.

Add selected activities to the new subproject
You can add several pactivities to a new subproject doing as follows:

1. Mark with the pressed left mouse button several activities

2. Finally, click on Start > Add > Subproject

In this case, the start and finish dates of activities are assumed as the start and the end of the Subproject.
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4.12.2 Insert subprojects from file

Insert a new subproject in the end of the activity table

• Choose the menu item Start > Insert > Subproject from file template

• The dialogue box Open appears.

• Select the project you want to insert.

• Set at the start or end of the subproject.

• You cannot assume the whole project but only selected activities as subproject by marking appropriate activities.
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• Click on the button OK.

Note:
Inserted from the file-template project should work with the same resource pool as the main project. If there is a
resource difference, the message appears.

You should open the project inserted from template separately in Rillsoft Project and switch to the resource pool.

Follow the instructions under Shift to the resource pool.
Insert a new subproject in any area in the Gantt chart

1. Set the cursor on a field in the Gantt chart where you want to insert a subproject.

2. Click the right mouse button and select the item from the context menu New subproject from template file.

3. Continue as described above.
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4.12.3 Insert subprojects from Rillsoft Integration Server template

Insert a new subproject in the end of the activity table

1. Select the menu item Start > Insert > Subproject from Rillsoft Integration Server template.

• The dialogue box Open appears.

• Select the project you want to insert.

• Set start or end of the subproject.

• You cannot assume the whole project but only selected activities as subproject by marking appropriate activities.
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5. Click on the button OK.
Note:
Inserted from the Rillsoft Integration Server-template project should work with the same resource pool as the main
project. If there is a resource difference, the message appears.

You should open the project inserted from Rillsoft Integration Server-template separately in Rillsoft Project and switch
to the resource pool.

Follow the instructions under Shift to the resource pool.
Insert a new subproject in any place in the Gantt chart

1. Set the cursor on a field in the Gantt chart where you want to insert a subproject.

2. Click the right mouse button and select the item from the context menu New subproject from Rillsoft Integra-
tion Server template.
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3. Continue as described above.

4.12.4 Edit subprojects

In order to edit a parameter of an existing subproject, do as follows:

• In the diagram click on the subproject whose parameter you want to edit.

• Activate the required tab in the window Properties and make the changes.

• Click on the button OK.

Alternative 1: You may make the changes to the most important subproject parameters directly in the table of the
Gantt chart.

Alternative 2: You may use the mouse to shift the subproject in the diagram, so as to change its time parameters or
duration.

Requirements: The subproject has fixed start and end dates.
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Alternative 3: You can use the context menu of the subproject to make substantial changes to it quickly.

4.12.5 Delete subprojects

In order to delete an existing subproject, do as follows:

• Rightclick on the subproject you want to delete.

• Choose the command Delete from the context menu.

Alternatively: You can quickly delete an existing subproject by clicking on the blank space in the diagram with the
right mouse button pressed down and striking out the subproject.
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4.12.6 Enter subproject properties

In order to define the subproject properties, do as follows:

• Mark the subproject whose properties you want to enter.

The window Object properties opens.

• Enter the subproject name in the field Name.

• Enter the subproject code in the field Code.

• Mark the check box Define if you don’t want to have the start and finish date of the subproject automatically
calculated, but want to define it manually instead.

• Enter the approximately start and finish dates of the subproject in the fields Start/Finish after you have marked
the check box Define.

• In the drop down list Project calendar select the calendar you want to use for the subproject.

• Click on the button OK.

Note:
• The field Baseline indicates whether a baseline is being used or not. This feature is defined in the main project.

• The field Time step indicates which interval is being used. This feature is defined in the main project.

4.12.7 Assign activities to subprojects

In order to assign activities to subprojects, do as follows:

• Mark the activity bars you want to move into a subproject.

• Select the menu item Start > Outline > Move in subproject.
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The dialogue box Select subproject opens.

• The activities will then be moved to the subproject and the activity numbering subordinated to the subprojects if
the WBS code has been set up accordingly.

4.13 Summary project

4.13.1 Summary project

A summary project contains several projects and allows:

• Cross-project capacity planning

• Optimal resource utilization between several projects

• Simulations

You can group selected projects into a summary project and later add them to a portfolio.
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Requirement: Only the projects in the summary project may be added, which use a common resource pool.

All views are available for the summary project, from the gantt chart to the resource chart. In the summary project
all activities like be carried out in a usual project, i.e. You can create tasks, allocate resources, correct activities, or
save results.

Note: A new Project can not be created in the summary project. You should create a new project separately and then
add to a summary project.

4.13.2 New Summary project in Rillsoft with interface to Rillsoft Integration Server

In order to open a new summary project, do as follows:

1. Select the menu item File > Open new summary project.
2. The dialogue window Rillsoft Integration Server summary project appears.
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3. Select the folder where the required projects are located. Or select individual projects, which are to be transferred
into the summary project. Enter a name for the summary project.

4. Click on the button OK.

Note: Although you can add to the summary project projects with resources different from the resource pool, but when
you open the summary project appears a note, that you should switch these projects with the menu item Project >
Project resources > Switch to Resource pool to the resource pool.
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4.13.3 Open a summary project in Rillsoft with interface to Rillsoft Integration
Server

In order to open a summary project, do as follows:

1. Select the menu item File > Open > Rillsoft Integration Server > summary project.
2. The dialogue Rillsoft Integration Server summary project appears.

3. Left, all summary projects are listed with information about project number in the summary project and number
of projects that are available for you, it is related to your access rights.

4. Right, you see all the projects from the selected summary project. You can take out individual projects from the
summary project for this time by deleting the marking of appropriate projects or all projects by click Select: All.

5. You can apply some projects read-only i.e. only to read in the summary project, by selecting them in Read-Only
column or all projects by click Readonly: All.
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You can see at once on a red background if any projects are locked as well.

6. Click on the button OK.

Note: Only projects that share a common resource pool can be included in the summary project.

If project resources are differrent from the resource pool, the message appears.

In order to have the summary project accepted projects with significant differences in resources, they must be opened
separately and you can switch from the project resource to the resource pool by means of the menu item Project >
Switch > Resource pool.
Locking

• Pessimistic – once a user edits something in the project, all other users can open the project only as a read-only
copy.

• Optimistic - each user can always edit the project.

The lock option is available only for the user, who also have the appropriate access rights.

Baselines load
Baseline slows the work with the summary project. If you do not need a comparison with a baseline at the moment,
you can open summary project without a baseline.

Set the order of the project in summary project
The projects shown in the list can be sorted according to the following parameters:

• Project name

• Code

• Category

• Priority

• Status

• Start of project

• Finish of project

• File names

Click on the selected column in the title area, e.g. Start.
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The selected order is then accepted by the summary project.

Change summary project properties
Click on the button Properties

If you want to add other projects to the list, click on the appropriate button to add either a folder or file.

4.13.4 Reload summary project

If you are working in a multi-user environment, it may often be necessary to reload a summary project on which several
people are working at the same time in order to view their changes.

This function reloads the current summary project.

• Click on the Reload icon on the Quick Access Toolbar.

Notes:

• If the Reload icon is not present, you can select Reload from the Customise Quick Access Toolbar menu item.
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4.13.5 Form a summary project from a split project

You can automatically convert an existing project, which consists of several sub-projects and is to be processed by
different teams, into a summary project in Rillsoft Project with an interface to the Rillsoft Integration Server.

In order to convert a project into a summary project, the following Prerequisites should first be fulfilled:

1. there should be at least one sub-project in the project.

2. there should be no separate activities at the top project level, i.e. all activities should be subordinate to some
subproject.

3. there should be no added documents at the top project level.

If the above requirements are not met, the function Project > Rillsoft Integration Server > Split Project is greyed
out.

To create a summary project, please proceed as follows:

1. open a project that you want to convert to a summary project.

2. check whether the project has been converted to a summary project.

3. If it does, select the menu item Project > Rillsoft Integration Server > Split Project.

4. In the dialogue window, Rillsoft Project shows us in the Name column how many separate projects the project
can be divided into.
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5. In the Path column, click three dots and select a directory from the virtual directory structure for each project.

6. The corresponding subdirectories for the projects are listed in the Subdirectory column.

7. By clicking the OK button, the original sub-projects are saved as projects and added to a summary project.

A corresponding message appears and after you click OK, the newly created summary project is opened. Although it
looks similar to the initial project, it is not, as a summary project enables multi-user work.
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4.13.6 Summary project archiving in Rillsoft with interface to the Rillsoft Integration
Server

Several separate projects belonging to the summary project are merged into one project.

To archive a summary project, please proceed as follows:

1. select the menu item Project > Rillsoft Integration Server > Archive summary project.

2. The dialogue Save Rillsoft Integration Server Project appears.

3. On the left, all virtual directories are listed. On the right you see all projects from the selected directory.

4. Click the OK button.

4.13.7 Cross-project links in summary project

In the summary project you can link several projects with each other. Important! This function is only included in
Rillsoft Project with Rillsoft Integration Server and links can only be edited in the summary project.

In cross-project links, succeeding activities are shifted not automatically, but the program sets negative intervals instead.
By means of the menu item Project > Rillsoft Integration Server > Cross-project links, you can check these links
and obtain detailed information about them, such as occurring delays.

You can choose whether you want to accept only single or all of the changes you have made to these settings.
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The following information and options are available:

Move The calculated delay will be compensated by the approved delay when you click on the
check box.

Outgoing project / ac-
tivity

Displays outgoing projects/activities.

Incoming project / ac-
tivity

Displays incoming projects/activities.

Start Shows, where a link starts.
Finish Shows, where a link ends.
Reserve Shows the interval between the outgoing and incoming positions in absolute time.
Delay, Release Displays the value of the released interval.
Delay, Calculation Displays the value of the calculated interval.

Red background colouring signals that there is a discrepancy between the released and the calculated delay.

Set to automatic
Click this button if all calculated delays should be automatically aligned with the released delays.

Types of links
The following link types are at your disposal:
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Finish-Start the “from” activity must finish before the “to” activity can start
Start-Start the “from” activity must start before the “to” activity can start
Finish-Finish the “from” activity must finish before the “to” activity can finish
Start-Finish the “from” activity must start before the “to” activity can finish

Time intervals
Intervals can be defined in Project properties in relation to the time unit of the duration (such as hours or days). Intervals
can only be defined in absolute time (estimated duration including non-working time, such as: 10 hours or 2 days).

Intervals can have

• positive (such as: + 2 hours) or

• negative (such as: - 50% = overlapping)

signs.

Highlight link
Links can be highlighted by means of colour or boldface.

Create cross-project link
New cross-project links can be only created by Rillsoft Project with Rillsoft Integration Server in the summary project.
In order to create a new cross-project link, do as follows:

• Choose the link type via the menu item Start > Insert > Link.

• Connect two activities by drawing your mouse from one activity of a
project to another activity from another project.

• If necessary, enter the delay (positive or negative) by which you want
to delay the “to” acticity depending on the selected link type.
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Note: If you do not enter any delay, the delay related to positions of outgoing and incoming activities is automatically
calculated.

• Click on the button OK.

4.14 Take over start and finish dates of a project from activities

Rillsoft Project allows you to define the start and finish dates of a project during the setup of this project.

A project’s duration is usually set by default for two weeks.

You may use the menu item Project > Schedule > Take over to recalculate project dates in relation to a start date of
the first activity and the finish date of the last activity.

4.15 Improve presentation of the project

In order to improve the project readability, do as follows:

• Show / hide all subprojects

• Number all activities and subprojects

• Change order in the Gantt charts

• Adjust timescale and calendar pane
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• Scale up/down display

• Create subprojects

• Add user view

Show / hide detail
In order to unfold all subprojects, select the menu item Start > Outline > Show/Hide detail.

Number all activities and subprojects
To each activity is automatically assigned a number during the activities creation After their linking or the schedule
correction, the numbers may not correspond to the correct time series.

In order to rearrange the numbers of activities - no matter whether it is a unique number or WBS code - , select the
menu item Project / Numbering. The activities will then be numbered automatically and unbrokenly.

Change order in the Gantt charts
In order to automatically change the order of all activities and subprojects, select the menu item Gantt chart format
> Data > Sort an

select one of the following menu items or icon buttons:

• by links

• by start time

• by code

• by name

Note: Different views can have different menu items.

Manually change
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In order to change automatically the order of a single marked activity or subproject

1. select the menu item Start > Edit >. . . an.

2. select one of the following menu items or icon buttons:

• up

• down

Adjust timescale and calendar pane
To display the project’s time, you can choose between minutes and quarters.

To adjust the timescale, you can select one of two options:

• Click the slide bar with the left mouse button on the right pane of the status bar and move the slider to the
preferred time-zoom setting.

• Click on the actual time display e.g. Week 1:2 with the left mouse button on the right pane of the status bar.
Then select other preferred representation from the list.
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Scale up/down display
When displaying the project, you can enlarge or reduce the project views.

Please click with the left mouse button in the right-hand area of the status bar on the current scale display, e.g. 120%.
Then select select other preferred representation from the list.
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4.16 Optimize a project

The purpose of project optimisation is to obtain a project schedule that meets a predefined finish date and which makes
optimal resources utilization.

In order to optimize a project, go to the menu item Project > Schedule > Other functions > Optimize resource
utilization.

Note:
• You can use the check box Fix in the window Activity properties (tab General, field Due date) to ensure that

the due date of the activity remains unchanged during optimisation.

• The optimisation process takes the fixed dates of the subprojects into account.

• The command Optimize resource utilization in the context menu of the subproject can be used to optimize
selected subprojects only.
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• The optimisation of personnel resources is done according to the following command structure: employee ->
teams -> roles (explanation: if it includes employees, teams or roles will be ignored in the optimisation).

Contingency reserve
The display of the contingency reserve provides an overview about the erliest possible start dates and latest possible
finish dates of activities and subprojects in the Gantt chart in case of changes in the project schedule.

In order to activate the view of the contingency reserve, do as follows:

• Select the menu item File > Options > General > Exended.

• Mark the check box Reserve time calculation.

• Select the menu item Gantt chart format > Show > Contingency reserve.
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4.17 Save project

In order to save a project, select the menu item File > Save or File > Save as.

• You can create a folder for your templates by clicking on File > Option > General > Default location in the
field Project.

Rillsoft with interface for the Rillsoft Integration Server
In order to save a project, select the menu item File > Save or Save as > Rillsoft Integration Server > Project.
Save to other formats
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Alternatively, you can save projects in other formats:

1. • in MS Project via XML

• in XML format for Web

Clicking on File > Export > . . . and mark as File type the appropriate format.

2. • MS Excel
Select the menu item View format > Data > Excel, for example Gantt chat format > Data > Excel

4.18 Save project as template

In order to save a project as template, select the menu item File > Save as template.

Note:
• We recommend you to remove all employees from the project by clicking on Project > Assistant > Employees

> Remove employees from activities.
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• You can create a folder for your templates by selecting the menu File > Option > General > Default location
in the field Templates.

4.19 Import of projects

4.19.1 Import

In order to import a project, select the menu item File > Import.
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• MS Project XML allows to import from MS Projects that used to be saved as XML files.

• Text file in CSV format allows to import simple scheduling data, such as project structure, name, start and end
dates by means of CSV Standard.

• XML for web allows to import XML files that used to be saved via the menu item File > Export.

4.19.2 Import from MS Project XML

In order to import from MS Project XML, do as follows:

1. Save a project as XML file by means of MS Project by selecting in the MS Project software the menu item File
> Save as and setting the file type in the appearing dialogue File type to XML format (*.xml).

2. In Rillsoft Project select the menu item File > Import > MS Project XML and select the required file. Resources
from the imported MS Project will be displayed and you should assign these different resource types in Rillsoft
Project.

3. Define each of the resources according to your requirements, this could be role, team, employee, machine type,
machinery, by marking the corresponding check box in the column of the table.

Mark all as:
If you want to mark all resources at a time, click on the appropriate button.

• If you want to mark all resources at a time, click on the appropriate button.

• Role - all resources are assigned as roles.
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• Team - all resources are assigned as teams.

• Employee - all resources are assigned as employees.

• Machine type - all resources are assigned as machine types.

• Machinery - all resources are assigned as machinery.

4. Click on the button OK.

4.19.3 Import text file CSV format

When importing from a text file Rillsoft project offers two Variants:

1. To determine a structure plan from WBS code, you define a column for WBS code in text file. That is, each row
contains an operation name.

2. Breakdown structure should be determined by grouping several text columns. You can capture several operations
per one row.

You can import from the text file:

• the project structure

• name of tasks

• their start dates and finish dates

• user fields (up to 20)

Sample of a text file:

Version 1 (breakdown structure is determined via WBS code):

WBS;Name;Start;Finish;Duration, hrs.;Effort, EH;Costs, €

1;Subproject1;25.08.2015 08:00;05.09.2015 17:00;80,00;200,00;10741,20
1.1;Task1;25.08.2015 08:00;29.08.2015 17:00;40,00;40,00;1520,00
1.2;Task2;28.08.2015 08:00;03.09.2015 17:00;40,00;80,00;3040,00

Version 2 (breakdown structure is determined by grouping several text columns):

Filiale;Services and miscellaneous;Pay compensation;24.01.2011 08:00;28.01.2011 16:00;
→˓Task 1
Filiale;Services and miscellaneous;Pay compensation;24.01.2011 16:00;01.02.2011 15:00;
→˓Task 2
Filiale;Services and miscellaneous;Pay compensation;28.01.2011 08:00;04.02.2011 17:00;
→˓Task 3
Filiale;Services and miscellaneous;Reimbursement claim;24.01.2011 16:00;01.02.2011 15:00;
→˓Task 7
Filiale;Services and miscellaneous;Pflegeversicherung;31.01.2011 08:00;04.02.2011 17:00;
→˓Task 9
Filiale;Services and miscellaneous;Long-term care insurance;31.01.2011 08:00;04.02.2011␣
→˓17:00;Task 10
Filiale;Sales;Candidate declarations;28.01.2011 08:00;04.02.2011 17:00;Task 13
Service Center client;Employer service;;31.01.2011 08:00;04.02.2011 17:00;Task 16
;;;24.01.2011 16:00;01.02.2011 15:00;Task 18

In order to import a text file as CSV file, do as follows:
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Step 1:
Select the menu item File > Import > Text file in CSV format.

• Activate the check box First row contains only headers, do not import if the first row should not be imported.

• In the drop down menu Separator for columns, select the separator you want to use to separate the individual
elements from each other.

• In the drop down menu Date and time format, select the format you want to use for the display of date and time
format in the text file.

• Select how should a structure plan be determined, that is, Variant 1 or Variant 2.

• The table lists information that can be accepted in the project.

• Click on the button Continue.

Step 2:
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• In the column Assignation, select a matching name for the specific property of a product from the drop down
menu.

Normally, the names are connected to the values in the column Columns.

• Click on the Finish button.

4.20 Export of projects

4.20.1 Export

In order to export a project, select the menu item File > Export.
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• MS Project XML allows you to export to MS Project per XML format.

• XML for Web allows you to export to XML files.

Export via selecting the menu item View > View format> Data > Excel
• MS Excel allows you to export to Excel files.

In Rillsoft project with interface to the Rillsoft Integration Server you can create different calendars via Add-Ons >
iCalendar >. . . :

• MS Outlook allows you to export to MS Outlook via iCalendar format.

4.20.2 MS Project XML

In order to export a project,

1. In Rillsoft Project
• select the menu item File > Export > MS Project XML
• Enter a name for the Rillsoft xml file

• Click on the button Save
2. In MS Project
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• select the menu item Open and select File type as XML format (*.xml).

• Select your Rillsoft xml file and then click on Open.

• Stay with the option As a new project and click Ok.
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4.20.3 Export to MS Excel

You can export the following views to the Excel:

• Activity views

– Gantt chart

• Resource views

– Employee

– Role

– Team

– Machine types

– Machine

– Material requirements

• Capacity views

– Employee

– Machine

Tip By means of a filter you can define the exported information concerning time and resources.
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How it looks in Rillsoft Project
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1. Click one of the views that you want to export to Excel. For example Start > Resource views > Employee

2. Structure the project information by setting Start > Outline > Structure >. . . . For example Project > Role >
Employee
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Then appears a note about the structure selection in the status bar.

3. Define the time scale. For example Week 1:2

4. If necessary, you can display more details by clicking**+**.
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5. Check which columns are to be exported clicking the menu item Resource view format > Data > Columns and
switch on/off the required columns.

6. Click Resource view format > Data > Excel and enter a name for the Excel file.

110 Chapter 4. Work with Project



Rillsoft Project, Release 9

4.20.4 Export to MS Outlook

You can export the following information of the project to the MS Outlook via iCalendar:

• user task

• portfolio task

• project task

Requirements:
• Interface to the Rillsoft Integration Server

• You should have appropriate access rights.
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1. Sign up in Rillsoft Integration Server by Web interface.
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2. Select the menu item ADD-ONS > iCalendar.

3. Select what information you want to display in Outlook as Calendar. For example Project calendar

4. Select a project from the list. For example Maschine AAA and click the column Aktion button Calendar.
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4.20.5 Export XML for Web

You can use the XML export to publish your project data in the intranet.

To publish the project in the Intranet/Internet, proceed as follows:

• Select the menu item File > Export > XML for Web
• Enter a file name

• Click on button Save
Then copy the project file in XML format on the Web server and create a reference to the file.
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CHAPTER

FIVE

RESOURCE MANAGEMENT

5.1 Create resources

5.1.1 Identify resources

Rillsoft Project provides two types of resources:

• Resource pool - a total list of resources which can be allocated to project activities. Resource pools can be used
for one or several projects.

• Project resources - resources which can be used for one project only.

Resources are: roles, teams, employees, material resources, materials and machines that can be assigned / allocated to
a project for the activity execution.

Ressource pool or project resources?
In general, if you open Rillsoft Project, the resource pool is active.

Name and path of the actual resource pool file are in the left corner of the status bar.

Caution: If you open the project and the resources used by this projects are different from the resource pool,

1. first, the message appears
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2. the program switches automatically from the resource pool to the project resources.

The status bar displays project resources used in the open project.

For manual switching between resource pool and project resources, there are two commands in the menu bar:

• Project / Shift to resource pool

• Project / Shift to project resources

If, for instance, the project resources are active, the menu item Project > Project resources > Project resources is not
available.

Shift project resources to resource pool
If the project resources match the resource pool, users do not recognize the shifting from one to the other resource. The
shifting to project resources does not require the user to take any additional action. If during the shifting process to the
resource pool, there are differences between project resources and resource pool, the program displays a list with the
deviations. Then, you can choose between using project resources and resource pool.

Creation and adjusting resources
In order to create resources in the resource pool, select the menu item File > Resource pool > Create.

Rillsoft with interface to Rillsoft Integration Server
Here you should create a client in the Rillsoft Integration Server surrounding by Web browser and then click on File >
Resource pool > Rillsoft Integration Server > Select
Here you can:

• adjust and edit existing resources

• create new resources manually

• import resources from a text file

5.1.2 Create new resource pool file

You find the resource pool in the file RillPrj.xml in the Rillsoft Project data folder. You can create a new resource pool.

Close all projects before creating a new resource pool.

• Select the menu item File > Resource pool > File > Create
• Enter a name for the new file *.xml in the opening dialogue window.

116 Chapter 5. Resource management



Rillsoft Project, Release 9

Note: The name of the actual resource pool file is shown in the left corner of the status bar. A project should then be
opened.

5.1.3 Create new resource pool in Rillsoft with interface to Rillsoft Integration
Server

The resource pool is in data base solution in your database. You can create a new resource pool,

1. by creating a new client in Rillsoft Integration Server Web interface.
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2. Enter a name for the client.

3. In Rillsoft Project click on File > resource pool > Rillsoft Integration Server > Select.
4. Select a client.
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Note: The name of the actual resource pool is shown in the left corner of the status bar. A project should then be
opened.

5.1.4 Import of the resource pool from resource pool file in Rillsoft Integration
Server

You can import a resource pool from Rillsoft xml file in the Rillsoft Integration Server.

1. First you should create a new client in Rillsoft Integration Server Web interface.
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2. Enter the client name.

3. In Rillsoft Project select the menu item File > resource pool > Rillsoft Integration Server > import an.
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4. Select a resource pool file in the dialog.

5. Click on Open.

Note: The name of the actual resource pool is shown in the left corner of the status bar. A project should then be
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opened.

5.1.5 Select other resource pool

When you first start the program, you find the resource pool as RillPrj.xml-file in the Rillsoft Project data folder. You
can choose another resource pool.

Close all projects before choosing another resource pool.

• Select the menu item File > resource pool > File > Select.
• Select the required file *.xml in the opening dialogue window.

Note: The name of the actual resource pool is shown in the left corner of the status bar. A project should then be
opened.
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5.1.6 Set and adjust calendars

In order to set and adjust calendars, do as follows:

• Select the menu item Start > Properties > Resource.

The dialogue box Resource pool opens.

• Select the tab Calendar.

• In order to create a new calendar, click on the button New calendar or enter a calendar name in the column
Name, which is marked with an asterisk (*).

Note: The list of calendars shows all the calendars that have been created. Mark one of the calendars to view detailed
information or to make changes.

• In the field Week define the worktime for each of the days in a week. Intervals can be separated by using a
semicolon (example: 08:00-12:00; 13:00-17:00).

• In the field Day define the non-working days. You can enter deviating worktimes for single days (such as Shrove
Tuesday). You can also define additional workdays.

• Mark the day in the calendar view you want to change.

• Select the Default Option, if you want to set the changes made to a day to its default weekday definition.
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• Select the Holiday Option, if the marked day is a holiday.

• Select the After day. . . Option, if the marked day should be subjected to the rules of another weekday. Select
the corresponding weekday definition from the drop down menu.

Note: If you change the worktimes in the weekday definition, the worktime of this day will be changed accordingly.

• You can select the**Exceptions Option** to define an individual worktime for the marked day.

Note: Any changes to the worktime in the weekday definition has no effects on this day.

Note: In order to delete a calendar, click on the button Delete calendar.

• Click on the button OK.

Download holidays
You can download official holidays for coming years and different federal states from our server to you program. Accept
these holodays by clicking on the button Load holidays. We recommend the following procedure:

• The dialogue window Load holidays appears.

• Select your calendar from the drop dowm menu Calendar, such as GER-all states.

• You can accept the holidays for the entire year by marking the check box next to the year date, such as 2015.

• Alternatively, you can mark only particular holidays and enter them in your calendar.

• Click on the button OK.
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5.1.7 Set and adjust roles

Rillsoft Project allows you to define roles in a flexible way, because you can set different quality ranks with graded cost
rates for roles. We recommend you to define roles in a way that allows you to manage them in groups. You should
define a group for each of the roles individually (example: floor tiler, carpenter, . . . )

Enter the qualification and corresponding cost rate directly in the group (example: carpenter - foreman, master, crafts-
man, apprentice, etc.).

In order to set and adjust roles, do as follows:

• Select the menu item Start > Properties > Resource.

The dialogue box Resource pool opens.

• Select the tab Roles.

• Create a new group by clicking on the button New group or on the row that is marked with an asterisk (*), enter
a new group name in the column Role.

• Enter a specific role in this group in the row (column Qualification).
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• You can enter more qualification ranks in the empty row below in the column Qualification, which copies the
group name automatically. Note: To change the role name, you need to do this in the first group row, which
automatically transfers the group name to all the other saved qualification ranks.

• Enter a specific value in the column Code to exchange data with other applications.

• Enter the costs per hour in the field Costs.
• After a particular date, you can enter either a coefficient for an existing unit price or a new unit price per hour

and role in the field Cost adjustment.
• If necessary, enter a note in the field Notes.
• Click on the button OK.

Import / export of roles
Click on the button Export to export a resource to a TXT file or on the button Import to import resources.

Import / export fields:
• [ID]

• [Role](required field)

• [Code]

• [Qualification](required field)

• [Costs]

• [Cost adjustment]

• [Notes]

The individual fields are separated by a hash key “#”.

Sample of an import file: #Stucco plasterer, plasterer##Foreman - construction#23.00##

Note:
• You can search for roles in the field Filter. Enter the search phrase (or a part of it) in the field.

5.1.8 Set and adjust teams

The team management in Rillsoft Project is very flexible: You can define teams by means of the assigned employees or
via fixed costs and capacities. We recommend you to define teams in a way that allows you to manage them in groups.
You should define a group for each of the teams individually (example: Team floor tiler, Team carpenter, . . . )

You enter the team name and the capacities directly in the group. (Example: Foreman - Team early shift, Team late
shift.)

In order to set and adjust teams, do as follows:

• Select the menu item Start > Properties > Resource.

The dialogue box Resource pool opens.
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• Select the tab Teams.

• Create a new group by clicking on the button New group or on the row that is marked with an asterisk (*), enter
a new group name in the column Working group.

• Enter a new team type in this group in the row (column Team).

• You can enter more team types in the empty row below in the column Team, which copies the group name
automatically. Note: To change the group name, you need to do this in the first group row, which automatically
transfers the group name to all the other saved team types.

• Enter a specific value in the column Code to exchange data with other applications.

• From the drop down list Calendar, select the calendar that should apply for this team. If you have not selected a
calendar, the program searches for a valid calendar in the following order : Activity calendar and project calendar.

• Enter the non-working days of the team (job trainings, workshops, etc.) in the field Non-working days. Note:
(Example for a definition of non-working days: 18.03.05-22.04.05; 25.05.05; 08.06.05-17.06.05).

• Select the option according to which you want to calculate the capacity and costs of the team in the drop down
menu Capacity type.

– Fixed: For manual capacity and costs fixing in the columns Capacity and Costs. Note: This option is only
applicable in case of the team definition by capacity and costs per hour, without assigning employees to the
teams. If you combine employees with teams, we recommend you to use one of the following options.

– Optimistic: The capacity and costs calculation is done on the basis of a higher level of productivity and
the corresponding cost rates of each employee.
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– Real: The capacity and costs calculation is done on the basis of the real cost rate and the corresponding
productivity level of each employee.

– Median: The capacity and costs calculationis done on the basis of the median value from the productivity
level and the cost rate of each employee.

Note: The options Optimistic, Real and Median provide different results only when an employee has been assigned
to several roles and is recorded with these several roles as team member.

• Enter the capacity for all team members, which is calculated in dependence to the selected type of calculation
in the field Capacity type (corresponds normally with the number of team members) in the field Capacity. You
can change this value in the option Fixed.

• In the field Costs, enter the total cost rate for all team members, which is calculated in dependence to the selected
type of calculation in the field Capacity type. You can change this value in the option Fixed.

• After a particular date, you can enter either a coefficient for an existing unit price or a new unit price per hour of
the team in the field Cost adjustment.

• If necessary, enter a note in the field Notes.
• Click on the button OK.

Import / export of teams
Click on the button Export to export a resource to a TXT file or on the button Import to import resources.

Import / export fields:

• [ID]

• [Working group](required field)

• [Code]

• [Team](required field)

• [Calendar]

• [Non-working days]

• [Capacity type]

• [Capacity]

• [Costs]

• [Cost adjustment]

• [Notes]

The individual fields are separated by a hash key “#”.

Sample of an import file:

#Underground construction###Team underground construction#######

Note:
• You can search for teams in the field Filter. Enter the search phrase (or a part of it) in the field.
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5.1.9 Set and adjust employees

The employee management in Rillsoft Project is very flexible. You can assign several different roles, team memberships,
costs and productivity to employees.

Note: We recommend you to create teams before you define employees.

In order to set and adjust employees,do as follows:

• Select the menu item Start > Properties > Resource.

The dialogue box Resource pool opens.

• Select the tab Employees.

• Create a new group or a new employee by clicking on the button New group or on the row that is marked with
an asterisk (*), enter a new employee name in the column Name.

• Enter the property of an employee (a new role or team membership) in this group in the row (columns Working
group – team and Role - qualification). You can enter additional properties of the employee directly in the
empty row below the column Working group - team and Role - qualification, while the group description is
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automatically copied. Note: In order to change the group name, at first you need to do this in the first group row,
which automatically transfers the group name to all the other saved material types.

• Enter a specific value in the column Code to exchange data with other applications.

• Enter an Email address of the employee in the column Email.
• From the drop down list Calendar select the calendar that should be applied for this employee. If you have not

selected a calendar, the program searches for a valid calendar in the following order: Team calendar, Activity
calendar and Project calendar.

• Enter the date the employee has entered the company in the field Entry.

• Enter the date the employee has left the company in the field Leaving.

• Click in the Shift calendar field if an employee is to work at different times according to different calendars. First
select a time period for a work calendar by holding down the left mouse button. Then select a desired calendar
for this time. The prerequisite is that the calendars to be selected should have been created in the resource pool
on the Calendar tab.
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• Enter the non-working days of the employee (job trainings, workshops, etc.) in the field Non-working days.
Note: The entered non-working days will be added to those defined in the team. (Example for a definition of
non-working days: 18.03.05-22.04.05; 25.05.05; 08.06.05-17.06.05).

• Select the team which you want the employee to be assigned to in the drop down list Working group - team.

• Select the role which you want to assign to the employee in the drop down list Role - qualification.
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• Enter a different value for the calculated productivity of an employee in percent in the field Productivity.

• Enter a different value for the calculated hourly rate of an employee (for instance, from the role definition) in the
field Costs.

• After a particular date, you can enter either a coefficient for an existing unit price or a new unit price per hour of
the employee in the field Cost adjustment.

• If necessary, enter a note in the field Notes.
• Click on the button OK.

Assign additional roles, teams, costs and productivity to an employee
If you want to assign a different role along with its different cost rate to an employee, do as follows:

• Enter the different value in the row of the employee directly below (no asterisk) in the corresponding column.
Caution: Make sure not to define this employee in another row, which features an asterisk, because this may
cause inconsistencies within the project.

Import / export of employees
Click on the button Export to export a resource to a TXT file or on the button Import to import resources.

Import / export fields:
• [ID]

• [First Name]

• [Last Name](required field)

• [Code]

• [Email]

• [Calendar]

• [Entry date]

• [Leaving date]

• [Non-working days]

• [Team]

• [Role]

• [Productivity]
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• [Costs]

• [Cost adjustment]

• [Notes]

The individual fields are separated by a hash key “#”.

The number you want to import from “#” symbols in imported txt file must always be 14. If more or less “#” symbols
are registered, you will get an error message

Example of an import file (only employee names and the corresponding hourly rates are imported):

#MA-1#N-MA-1#1000001#MA1.NMA1@musterfirma.com######11.001 Team 1#11.001 Role 1####

oder

#MA-1#N-MA-1#1000001#MA1.NMA1@musterfirma.com###########

Note:
• You can search for employees in the field Filter. Enter the search phrase (or a part of it) in the field.

5.1.10 Set and adjust materials

We recommend you to define materials (consumables) in a way that allows you to manage them in groups. You may
define a group for each of the materials (for instance: group gravels. . . ).

Manufacturer, type of material, measurement unit and costs are then entered in the group. (Example: gravel - grit,
ballast, etc.)

In order to set and adjust materials, do as follows:

• Select the menu item Start > Properties > Resource.

The dialogue box Resource pool opens.

• Select the tab Material.
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• Create a new group by clicking on the button New group or on the row that is marked with an asterisk (*), enter
a new group name in the column Material group.

• Enter a new material type in this group in the row (column Material type). You can enter more material types
in the empty row directly below in the column Description, which copies the group name automatically.

Note: To change the group name, at first, you need to do this in the first group row, which automatically transfers the
group name to all the other saved material types.

• Enter a specific value in the column Code to exchange data with other applications.

• Enter the description / manufacturer, etc. of the material type in the field Material type.

• Enter the measurement unit of the material type (example: tons, square metres, piece, etc.) in the field Mea-
surement unit.

• Enter the costs per measurement unit in the field Unit price.

• After a particular dateyou can enter either a coefficient for an existing unit price or a new unit price per measure-
ment unit of the material in the field Price adjustment.

• If necessary, enter a note in the field Notes.
• Click on the button OK.

Import / export of materials
Click on the button Export to export a resource to a TXT file or on the button Import to import resources.

Import / export fields:
• [ID]

• [Material group](required field)
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• [Code]

• [Material type](required field)

• [Measurement unit]

• [Unit price]

• [Price adjustment]

• [Notes]

The individual fields are separated by a hash key “#”.

Sample of an import file: #Building construction - Ready-mixed concrete##Ready-mixed concrete BI: B 5 KS 0/32
HOZ 35L#m3#122.00##

Note:
• You can search for material groups, material types or the material code in the field Filter. Enter the search phrase

(or a part of it) in the field.

5.1.11 Set and adjust machine types

We recommend you to define machine types in a way that allows you to manage them in groups. You may define a
group for each of the machine types (for instance: lifting davits, tower cranes . . . ).

Manufacturer and machine or device type are then defined within the group (Example: Lifting davits - Lifting davit
type 10 to, Lifting davit type 100 to, etc.)

In order to set and adjust machines,do as follows:

• Select the menu item Start > Properties > Resource.

The dialogue box Resource pool opens.

• Select the tab Machine types.
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• Create a new group by clicking on the button New group or on the row that is marked with an asterisk (*), enter
a new group name in the column Machine group.

• Enter a new machine type in this group in the row (column Description). You can enter more machine types in
the empty row below in the column machine type, which copies the group name automatically. Note: To change
the group name, at first, you need to do this in the first group row, which automatically transfers the group name
to all the other saved machine types.

• Enter a specific value in the column Code to exchange data with other applications.

• Enter the description / manufacturer, etc. of the machine type in the field Machine type.

• Enter the measurement unit of the tool or machine type (example: piece, etc.) in the field Measurement unit.
• Enter the costs per hour of the machine type in the field Unit price.

• After a particular date you can enter either a coefficient for an existing unit price or a new unit price per hour and
machine type in the field Price adjustment.

• If necessary, enter a note in the field Notes.
• Click on the button OK.

Import / export of machine types
Click on the button Export to export a resource to a TXT file or on the button Import to import resources.

Import / export fields:
• [ID]

• [Machine group](required field)
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• [Code]

• [Machine type](required field)

• [Measurement unit]

• [Unit price]

• [Price adjustment]

• [Notes]

The individual fields are separated by a hash key “#”.

Sample of an import file:

#Construction machines - Dredgers##Demolition dredges - Caterpillar#Pcs.#32.00##

Note:
• You can search for machine groups, machine types or the machine type code in the field Filter. Enter the search

phrase (or a part of it) in the field.

5.1.12 Set and adjust machinery

The machinery management in Rillsoft Project is very flexible. You can allocate a machine to machine types and to
unit prices or to price adjustments.

Manufacturer and machine or device type are then defined within the group. (Example: Lifting davits - Lifting davit
type 10 to, Lifting davit type 100 to, etc.

In order to set and adjust machinery,do as follows:

• Select the menu item Start > Properties > Resource.

The dialogue box Resource pool opens.

• Select the tab Machinery.
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• Create a new group by clicking on the button New group or on the row that is marked with an asterisk (*), enter
a new group name in the column Machine name.

• Enter a specific value in the column Code to exchange data with other applications.

• Select the team which you want the machine to be allocated to in the drop down list Working group - team.

• Select the machine type which you want to be allocated to the machine in the drop down list Machine group -
machine type.

• Enter the costs per hour of the machine in the field Unit price.

• After a particular date, you can enter either a coefficient for an existing unit price or a new unit price per hour
and machine in the field Price adjustment.

• If necessary, enter a note in the field Notes.
• Click on the button OK.

Import / export of machinery data
Click on the button Export to export a resource to a TXT file or on the button Import to import resources.

Import / export fields:
• [ID]

• [Machine name](required field)

• [Code]

• [Working group - team]

138 Chapter 5. Resource management



Rillsoft Project, Release 9

• [Machine group - machine type](required field)

• [Measurement unit]

• [Unit price]

• [Price adjustment]

• [Notes]

The individual fields are separated by a hash key “#”.

Sample of an import file: #Construction machines - Dredgers##Demolition dredges - Caterpillar#Pcs.#32.00##

Note:
• You can search for machine names, machine types or the machine code in the field Filter. Enter the search phrase

(or a part of it) in the field.

5.1.13 Set and adjust project categories

Rillsoft Project allows you to summarize project categories in Groups in a flexible way.

In order to set and adjust project categories, do as follows:

• Select the menu item Start > Properties > Resource.

The dialogue box Resource pool opens.

• Select the tab Project categories.
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• Create a new group by clicking on the button New group or on the
row that is marked with an asterisk (*), enter a new group name in the column Group.

• Enter a specific project categories in this group in the row
(column Name).

• You can enter more category ranks in the empty row directly below in the
column Name, which copies the group name automatically. Note: To change the category name, you need
to do this in the first group row, which automatically transfers the group name to all the other saved category
ranks.

• Enter a specific value in the column Code to exchange data with
other applications.

• If necessary, enter a note in the field Notes.
• Click on the button OK.

Note:
• You can search for project categories in the field Filter. Enter the search phrase (or a part of it) in the field.
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5.1.14 Set and adjust project status

Rillsoft Project allows you to summarize the project status in groups in a flexible way.

In order to set and adjust the project status, do as follows:

• Select the menu item Start > Properties > Resource.

The dialogue box Resource pool opens.

• Select the tab Project status.

• Create a new group by clicking on the button New group or on the
row that is marked with an asterisk (*), enter a new group name in the column Group.

• Enter a specific project status in this group in the row
(column Name).

• You can enter more status ranks in the empty row directly below in
the column Name, which copies the group name automatically. Note: To change the status name, you need
to do this in the first group row, which automatically transfers the group name to all the other saved status
ranks.
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• Enter a specific value in the column Code to exchange data with
other applications.

• If necessary, enter a note in the field Notes.
• Click on the button OK.

Note:
• You can search for the project status in the field Filter. Enter the search phrase (or a part of it) in the field.

5.1.15 Set and adjust project customers

Rillsoft Project allows you to summarize project customers in Groups in a flexible way.

In order to set and adjust project customers, do as follows:

• Select the menu item Start > Properties > Resource.

The dialogue box Resource pool opens.

• Select the tab Project customers.
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• Create a new group by clicking on the button New group or on the
row that is marked with an asterisk (*), enter a new group name in the column Group.

• Enter a specific project customers in this group in the row
(column Name).

• You can enter more customers ranks in the empty row directly below in the
column Name. In the following columns, you can enter further project-relevant information related to the
customer, such as the address and contact data of a contact person.

• If necessary, you can add several addresses or contact person to a client in the directly following empty
lines.

Thereby the group name in the Name column is automatically copied as well.

Note: To change the client name, you need to do this in the first group row, which automatically transfers
the group name to all the other saved client ranks.

• Enter a specific value in the column Code to exchange data with
other applications.

• If necessary, enter a note in the field Notes.
• Click on the button OK.

Note:
• You can search for project customers in the field Filter. Enter the search phrase (or a part of it) in the field.

5.2 Update resource pool

It might be useful to reload a resource pool that has been changed by a responsible person in order to apply the changes.

This function reloads the current resource pool.

• Click on the Update Resource Pool icon in the left corner of the status bar.

5.3 Assign resources

5.3.1 Resource allocation

Rillsoft Project provides you two variants of resource allocation:

• to allocate resources to an activity. First choose an activity in the Gantt chart and then select the resources,
such as roles or employees, from the window Activity properties in the tabs. Then you may allocate the required
resource accordingly.

• to allocate activities to a resource. First define a resource in one of the Resource utilization views and then,
select the activities, to which you want to assign the resources, in the window Resource properties.

• Personnel assign assistant. If you have already defined personnel resources in the project in the form of roles,
you can assign the employees to activities semi-automatically.
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Important! A project schedule including activities should have been set up and the required resources, such as roles,
teams and personnel need to be defined before the assignation time.

Check if you are working with a resource pool. There should be no project resources. If in the status bar is shown the
Word project resources, then you should switch to the resource pool.

Allocate resources to an activity
In order to allocate an activity resource, proceed as follows:

• Select the menu item**Start > Activity views > Gantt chart**.

• Choose an activity either by selecting it from the Activity table or by leftclicking on it in the Gantt chart field.
The activity will be marked and the information is shown in the lower part of the Properties window.

• Select one of the tabs with the resources, such as Roles, Teams, Employees, Machines etc., depending on what
resource you want to allocate.

• The left table shows resources from the resource pool.

• Doubleclick on one of these resources.

• You can allocate several resources to one activity at a time. There, you can define the required quantity, utilization
and effort and verify the readiness and availability of personnel resources.

• Finally, click OK.

Allocate activities to a resource
• Select one of the resource views such as Role, Team or Employee.

Tip! If roles have already been assigned, you can use the Capacity view personnel to assign employees to activities
easily.

• In the filter Start > Edit > Filter, deactivate the option Offer only used resources for selection, to have all
resources from the resource pool shown in the table.

• Choose a resource either by selecting it from the resources table or by leftclicking on it in the timescale field. The
resource will be marked and the corresponding information is shown in the lower part of the Properties window.

• Select the tab Activities.
• Mark the check boxes of the activities.

• You can define different parameters of each resource for an activity.

• In this way, you can assign several activities to one resource at a time.

• Click on the button OK.

Personnel assign Assistant
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Requirements: In order to assign employees to activities, at first, you need to assign personnel resources in the form
of roles.

By means of the menu item Project > Assistant > Employee > Assign employees to activities, you can:

• The first step is to define what employees you want to assign.

• The second step is to mark the activities.

• Analyse and confirm the provided employee assignation.

Possible conflicts or overloads are marked in red. For this, there will be no automatic assignation / allocation.

5.3.2 Assign activities to a role in the view Role

In order to assign activities to a role, do the following:

• Select the view Start > Resource views > Role.

• Select the menu item Start > Edit > Filter.

The dialogue box Filter opens.
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• Remove the tick from the check box Offer only used resources for selection to view all roles from the resource
pool in the list.

• You can mark the check box Roles and transfer all roles to the view Role usage. Alternatively you can mark
only selected roles.

• Click on the button OK.

• Select a role which you want to assign activities to in the table of the view Role usage. The tab Activities in the
window Resource properties lists activities from the project schedule.
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• Mark the check boxes of the activities.

• Among others, you can define the quantity, usage and effort of a role for an activity.

• Click on the button OK.

Role properties during assignation
During the assignation you can refine role properties by controlling and defining the following values for each activity:

• Number of roles

• Usage of a role

• Effort of a role

• Notes concerning a role.

Activity selection
During this assignation you can determine the activity list by activating /deactivating the following options:

• Assigned activities only lists only assigned activities.

Activities at a specific date
You can filter activities that are due at a specific date. If you leftclick on a cell showing the result from the row Roles
and column Date, you will only receive the displayed activities that were defined for this particular time period.
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5.3.3 Role View Resource Properties

If you click on a row in the table at a role view, you can display detailed information about the role in the properties
window.
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The role information can be tracked on the following tabs:

• Activities

• Role

Activities

In the No. column you can assign the activities to the selected role by selecting it.

More information about the activities is available here.

The option Only assigned activities reduces the activity list to the activities that have already been assigned.

Role

You can see the properties of the role entered in the resource pool from the tab.

Activities on specific date
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You can filter out activities that are due on a certain date. If you click with the left mouse button on a cell which is a
result of the role line and the date column, you will only get the activities that are in question for the selected period.

5.3.4 Assign activities to a team in the view Team

In order to assign activities to a team, do the following:

• Select the view Start > Resource views > Team.

• Select the menu item Start > Edit > Filter.

The dialogue box Filter opens.
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• Remove the tick from the check box Offer only used resources for selection to view all teams from the resource
pool in the list.

• You can mark the check box Roles and transfer all teams to the view Team usage. Alternatively, you can mark
only selected teams.

• Click on the button OK.

• Select a team which you want to assign activities to in the table of the view Team usage. The tab Activities in
the window Resource properties lists activities from the project schedule.
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• Mark the check boxes of the activities.

• Among others, you can define the team usage and effort for an activity.

• Mark the check boxes of the activities.

• Click on the button OK.

Team properties during assignation
During the assignation you can refine team properties by controlling and defining the following values for each activity:

• Readiness of a team

• Availability of a team

• Capacity of a team

• Usage of a team

• Effort of a team

• Notes concerning a team.

Activity selection
During the assignation you can determine the activity list by activating /deactivating the following options:

• Assigned activities only lists only assigned activities.

Activities at a specific date
You can filter activities that are due at a specific date. If you leftclick on a cell showing the result from the row Team
and column Date, you will only receive the displayed activities that were defined for this particular time period.
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5.3.5 Team View Resource Properties

If you click on a row in the table at a team view, you can display detailed information about the team resource in the
properties window.

The Team information can be followed on the following tabs:

• Activities

• Team
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• Team members

Activities

Information about the activities is available here.

The option Only assigned activities reduces the activity list to the activities that have already been assigned.

Team

On the tab, you can see the properties of the team entered in the resource pool.

Team members

The tab lists other employees with their properties from the resource pool who belong to the same team.

Vorgänge zu bestimmtem Datum
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You can filter out activities that are due on a certain date. If you click with the left mouse button on a cell which is a
result of the team line and the date column, you will only get the activities that are in question for the selected period.

5.3.6 Assign activities to an employee in the Human resource capacity planning

Important! You should already have the following completed:

• Set up employees in the resource pool and describe them with roles.

• Assign the roles to the activities.

In order to assign activities to employees, do the following:
1. Select the menu item Start > Capacity views > Employee.

2. Mark unhide employees in the Human resource capacity planning to display employees.

3. Select the employee who you want to assign activities to. The tab Activities in the window Resource properties
lists activities from the project schedule.

Tip If you have the option Activities with matching role only activated, the employees will be offered only activities,
which this role has been assigned.
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4. Mark the check boxes of the activities.

5. Among others, you can define the employee workload for an activity.

6. Mark the check boxes of the corresponding activities.

7. Click on the button OK.

Employee properties during assignation
During the assignation you can refine role properties by controlling and defining the following values for each activity:

• Readiness of an employee

• Availability of an employee

• Productivity of an employee

• Workload of an employee

• Absence of an employee

• Effort of an employee

• Notes concerning an employee.

Activity selection
During the assignation you can determine the activity list by activating /deactivating the following options:

• Assigned activities only lists only assigned activities.

• Activities with matching role only is important for employee assignation. It lists only activities, to which a role
executed by an employee, has already been assigned.

Activities at a specific date
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You can filter activities that are due at a specific date. If you leftclick on a cell showing the result from the row Resource
and column Date, you will only receive the displayed activities that were defined for this particular time period.

5.3.7 Assign activities to an employee in the view Employee

Important! A project schedule, which includes activities and the employees required in the resource pool should
already been set up.

In order to assign activities to employees, do the following:

• Select the view Start > Resource views > Employee.

• Select the menu item Start > Edit > Filter.

The dialogue box Filter opens.
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• Remove the tick from the check box Offer only used resources for selection to view all employees from the
resource pool in the list.

• You can mark the check box Employees and transfer all employees to the view Employee workload. Alterna-
tively you can mark only selected employees.

• Click on the button OK.

• Select the employee which you want to assign activities to in the table of the view Employee workload. The tab
Activities in the window Resource properties lists activities from the project schedule.
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Tip If an employee has several roles, the activity will be shown as many times as the number of roles the employee has.
For instance, Mr Ordentlich can work as mechanic, which means all activities will be listed twice, so as to allow him
to be assigned to one activity under several roles.

• Mark the check boxes of the activities.

• Among others, you can define the employee workload for an activity.

• Mark the check boxes of the activities.

• Click on the button OK.

Employee properties during assignation
During the assignation you can refine role properties by controlling and defining the following values for each activity:

• Readiness of an employee

• Availability of an employee

• Productivity of an employee

• Workload of an employee

• Absence of an employee

• Effort of an employee

• Notes concerning an employee.

Activity selection
During the assignation you can determine the activity list by activating /deactivating the following options:

• Assigned activities only lists only assigned activities.

• Activities with matching role only is important for employee assignation. It lists only activities to which a role
executed by an employee has already been assigned.
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Activities at a specific date
You can filter activities that are due at a specific date. If you leftclick on a cell showing the result from the row Employee
and column Date, you will only receive the displayed activities that were defined for this particular time period.

5.3.8 Employee View Resource Properties

If you click on a row in the table at a employee view, you can display detailed information about the employee resource
in the properties window.

The employee information can be followed on the following tabs:
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• Activities

• Employee

• Calendar

• Team members

Activities

In the No. column, you can assign the activities to the selected person by marking them.

This provides you with further information about the activities.

The option Only assigned activities reduces the activity list to the activities already assigned.

Only activities with matching role only those activities are listed to which a role exercised by the employee is already
assigned.

In addition, you can refine the personnel characteristics in the table when making the assignment, by checking the
following values for each activity:

• On-call of an employee

• Availability of an employee

• Additional utilization of an employee

• Negative effort of an employee

• Substitution for which employee

or define the following values:

• Productivity of an employee

• Utilisation of an employee

• Absence of an employee

• Effort of an employee

• Notes of an employee.

Employee
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On the tab, you can see the characteristics of a human resource entered in the resource pool, including its professional
qualifications.

Calendar

On the Calendar tab, you can see which calendars are used in the assigned tasks and how the working times are defined.

Team members

The tab lists other team members of his team with their properties from the resource pool.

Activities on specific date

You can filter out transactions that are due in a certain period of time. If you click with the left mouse button on a cell
that is a result of the employee row and the date column, you will only see the activities that come into question for the
selected period.
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5.3.9 Assign activities to a material in the view Material requirements

In order to assign activities to a material, do as follows:

• Select the view Start > Resource views > Material requirements.
• Select the menu item Start > Edit > Filter.

The dialogue box Filter opens.
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• Remove the tick from the check box Offer only used resources for selection to view all materials from the
resource pool in the list.

• You can mark the check box Material and transfer all materials to the view Material requirements. Alternatively,
you can mark only selected materials.

• Click on the button OK.

• Select the material which you want to assign activities to in the table of the view Material requirements. The tab
Activities in the window Resource properties lists activities from the project schedule.
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• Mark the check boxes of the activities.

• Among others, you can define the material quantity for an activity.

• Mark the check boxes of the activities.

• Click on the button OK.

Material properties during assignation
During assignation you can refine material properties by controlling and defining the following values for each activity:

• Calculation of a material

• Quantity of a material

• Notes concerning a material.

Activity selection
During this assignation you can determine the activity list by activating /deactivating the following options:

• Assigned activities only lists only assigned activities.

Activities at a specific date
You can filter activities that are due at a specific date. If you leftclick on a cell showing the result from the row Material
and column Date, you will only receive the displayed activities that were defined for this particular time period.
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5.3.10 Material requirement Properties

If you click on a row in the table at a Material requirement view, you can display detailed information about the material
requirement in the properties window.

The machine type information can be tracked on the following tabs:

• Activities

• Material requirement

Activities

In the No. column you can assign the activities to the selected material by selecting it.

More information about the activities is available here.

The option Only assigned activities reduces the activity list to the activities that have already been assigned.

Material

You can see the properties of the machine type entered in the resource pool from the tab.

Activities on specific date
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You can filter out activities that are due on a certain date. If you click with the left mouse button on a cell which is
a result of the material line and the date column, you will only get the activities that are in question for the selected
period.

5.3.11 Assign activities to a machine type in Machine types

Important! A project schedule, which includes activities and the roles required in the resource pool should already
been set up.

In order to assign activities to a machine type, do the following:

• Select the view Start > Resource views > Machine types.
• Select the menu item Start > Edit > Filter.

The dialogue box Filter opens.
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• Remove the tick from the check box Offer only used resources for selection to view all machine types from the
resource pool in the list.

• You can mark the check box Roles and transfer all machine types to the view Machine type usage.

Alternatively ,you can mark only selected machine types.

• Click on the button OK.

• Select a machine type which you want to assign activities to. The tab Activities in the window Resource prop-
erties lists activities from the project schedule.
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• Mark the check boxes of the activities.

• Among others, you can define the quantity, utilization and notes of a machine type for an activity.

• Mark the check boxes of the activities.

• Click on the button OK.

Machine type properties during allocation
During the allocation you can refine role properties by controlling and defining the following values for each activity:

• Number of machine type

• Usage of machine type

• Notes concerning a machine type

Activity selection
During the assignation you can determine the activity list by activating /deactivating the following options:

• Assigned activities only lists only assigned activities.

Activities at a specific date
You can filter activities that are due at a specific date. If you leftclick on a cell showing the result from the row Machine
type and column Date, you will only receive the displayed activities that were defined for this particular time period.
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5.3.12 Machine types Resource properties

If you click on a row in the table at a machine type view, you can display detailed information about the machine type
in the properties window.

The machine type information can be tracked on the following tabs:

• Activities

• Machine types

Activities

In the No. column you can assign the activities to the selected machine type by selecting it.

More information about the activities is available here.

The option Only assigned activities reduces the activity list to the activities that have already been assigned.

Machine types

You can see the properties of the machine type entered in the resource pool from the tab.
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Activities on specific date

You can filter out activities that are due on a certain date. If you click with the left mouse button on a cell which is a
result of the machine type line and the date column, you will only get the activities that are in question for the selected
period.

5.3.13 Assign activities to machines in the view Machine usage

Important! A project schedule, which includes activities and the machines required in the resource pool should already
been set up.

In order to assign activities to a machine, do the following:

• Select the view Start > Resource views > Machine.

• Select the menu item Start > Edit > Filter.

The dialogue box Filter opens.
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• Remove the tick from the check box Offer only used resources for selection to view all machines from the
resource pool in the list.

• You can mark the check box Roles and transfer all machines to the view Machine usage.

Alternatively, you can mark only selected machines.

• Click on the button OK.

• Select a machine which you want to assign activities to in the table of the view Machine usage. The tab Activities
in the window Resource properties lists activities from the project schedule.
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• Mark the check boxes of the activities.

• Among others, you can define the machine usage for an activity.

• Mark the check boxes of the activities.

• Click on the button OK.

Machine properties during assignation
During the assignation you can refine machine properties by controlling and defining the following values for each
activity:

• Availability of a machine

• Usage of a machine

• Notes concerning a machine.

Activity selection
During the assignation you can determine the activity list by activating/deactivating the following options:

• Assigned activities only lists only assigned activities.

Activities at a specific date
You can filter activities that are due at a specific date. If you leftclick on a cell showing the result from the row Machine
and column Date, you will only receive the displayed activities that were defined for this particular time period.
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5.3.14 Machinery properties

If you click on a row in the table at a machine view, you can display detailed information about the machine in the
properties window.

The machine information can be tracked on the following tabs:

• Activities

• Machine

• Team members

Activities

In the No. column, you can assign the activities to the selected machine by marking them.

This provides you with further information about the activities.

The option Only assigned activities reduces the activity list to the activities already assigned.

Only activities with matching role only those activities are listed to which a role exercised by the machine is already
assigned.

Machine
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On the tab, you can see the characteristics of a machine entered in the resource pool, including its machine type.

Team members
The tab lists other machines with their properties from the resource pool if the machines are grouped into a team.

Activities on specific date

You can filter out transactions that are due in a certain period of time. If you click with the left mouse button on a cell
that is a result of the machine row and the date column, you will only see the activities that come into question for the
selected period.

5.3.15 Resource utilization

Information about activities to which the resources have been allocated. In all views of Resource Usage, such as

• Role

• Team

• Employee

• Machine types

• Machinery

• Material

you can view the activities that cause the utilization from the opened project as well as the portfolio.

In order to view an overview of the activities, do as follows:
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• Click on a cell that shows the resource allocation. The window Object properties with the subordinated activities
appears in the lower part of the program window.

• These activities are displayed not as bars in the diagram, but as list in the Properties window.

• The overload of an employee, which happens because of simultaneous assignments in other projects, is marked
in red.

• It will become significant if the assigned employees or allocated machines are not only participating in the actual
project, but are also the part of other projects within the company.

Tip You can select a portfolio for a project, by

• Clicking on a vacancy of the Gantt chart area
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• click on button in the properties window and select portfolio from the list

• all projects of the portfolio are listed in the tab portfolio dashboard.

5.4 Automatically assign resources

5.4.1 Assign employees to activities

Requirements: In order to assign employees to activities, at first you need to assign personnel resources in the form
of roles.

The automatic staff assignment consists of three steps:

1. Select employees

2. Select activities

3. Assign employees

In order to assign employees to activities semi-automatically, please follow these steps:

• Select the menu item Project > Employee > Assign employees to activities.
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The dialogue box Employee assignment - Step 1 of 3: Choice of employees opens.

The list includes all the employees you can assign to activities or reassign to other activities by selecting them in Step
1.

Employees are grouped together in teams, while employees not being part of a team are shown at the lower end of the
list.

• Calendar - predefined calendar of the employee.

• Week - average working hours per week.

• On-call - percentage of the possible working capacity of an employee within project duration, adjusted for the
reported non-working days (holidays/sickness).

• Click the check boxes of the employees you would like to assign to activities in the column No.. You may also
click on the button Select all.
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• Click on the button Continue. The dialogue box Employee assignment - Step 2 of 3: Choice of activities
opens.

This list provides you with all the activities you can later assign employees to.

• The activities provided for selection reflect the structure of the project.

• Click on the check boxes for the activities to whom you want to assign employees. You may also click on the
button Select all.

• Click on the button Continue. The dialogue box Employee assignment - Step 3 of 3: Assigning activities to
employees opens.
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This list includes all the selected employees you can assign to the selected activities in Step 3.

Employees can be assigned to an activity if their role and qualification meet the demands of the activity.

Assignations are automatically evaluated and have an effect on succeeding activities (white: assignation possible, grey:
assignation not possible as already covered by an employee, red: assignation possible, but time conflicts occur).

• On-call - percentage of the possible working capacity of an employee within activity duration, adjusted for the
reported non-working days (holidays/sickness).

• Role - role of the employee.

• Effort - number of required employees for the activity and effort.

• Start - scheduled start of the activity.

• Finish - scheduled finish of the activity.

• Click on the check box for the activity you want to assign to an employee (for instance, because the employee
can be on-call for 100% of the total activity duration). Assignation options are dynamically adjusted.

Note: During assignination we recommend you to use the following strategy to avoid resources overload: first, assign
activities to employees who can cover activities at 100% (column On-call) and productivity at 100%.

• Repeat Step 6, if necessary. You may also click on the button Assign employees automatically.

• Click on the button Finish.

Important! Possible conflicts and overloads are indicated in red, and there is no automatic assignation.
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5.4.2 Remove employees from activities

You can automatically remove the employee assigned to the tasks.

The automatic removal of employees resources consists of two steps:

1. Select employee

2. Select activities

To automatically deduct employees from the activities, please proceed as follows:

1. • Select the menu item Project > Employee > Remove the employee from activities.

The dialogue box Employee deduction - Step 1 of 2: Choice of employee opens.

The list includes all the employees you can deduct from activities by selecting them in Step 1.

Employees are grouped together in teams, while machines not being part of a team are shown at the lower end of the
list.

• Calendar - predefined calendar of the employee.

• Week - average working hours per week.
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• On-call - percentage of the possible working capacity of an employee within project duration, adjusted for the
reported non-working days (holidays/sickness).

• Select the check boxes by the employees in the No. column that you want to deduct from activities. You may
also click on the button Select all.

• Click on the button Continue. The dialogue box Employee deduction - Step 1 of 2: Choice of activities opens.

This list shows you all the activities of the project or portfolio.

• The activities offered for selection reflect the structure of the project.

• Click on the check box for the activity from which you want to subtract the employees. You may also click on
the button Select all.

• Click on the button Finish.

5.4.3 Assign machinery to activities

Requirements: In order to assign machines to activities, at first you need to assign personnel resources in the form of
roles.

In order to assign machines to activities semi-automatically, please follow these steps:

• Select the menu item Project > Machine > Assign machines to activities.
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The dialogue box Assigning machines - Step 1 of 3: Selection of machines opens.

The list includes all the machines you can assign to activities or reassign to other activities by selecting them in Step 1.

Machines are grouped together in teams, while machines not being part of a team are shown at the lower end of the list.

• Machine group-machine type - to which type of machine does the machine belong.

• Costs - Operating costs per hour.

• Click the check boxes of the machines you would like to assign to activities in the column No.. You may also
click on the button Select all.

• Click on the button Continue. The dialogue box Assigning machines - Step 2 of 3: Selection of activities
opens.
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This list provides you with all the activities you can later assign machines to.

• The activities provided for selection reflect the structure of the project.

• Click on the check boxes for the activities to whom you want to assign machines. You may also click on the
button Select all.

• Click on the button Continue. The dialogue box Assigning machines - Step 3 of 3: Assigning machines to
activities opens.

This list includes all the selected machines you can assign to the selected activities in Step 3.
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Machines can be assigned to an activity if their group and type meet the demands of the activity.

Assignations are automatically evaluated and have an effect on succeeding activities (white: assignation possible, grey:
assignation not possible as already covered by an machine, red: assignation possible, but time conflicts occur).

• Machinery - Machine type of the machine.

• quantity-effort - Quantity of machines required for the activity and effort.

• Start - Planned start of activity.

• Finish - Planned finish of activity.

• Click on the check box for the activity you want to assign to an machine. Assignation options are dynamically
adjusted.

• Repeat Step 6, if necessary. You may also click on the button Assign machines automatically.

• Click on the button Finish.

Important! Possible conflicts and overloads are indicated in red, and there is no automatic assignation.

5.4.4 Remove machinery from activities

You can automatically remove the machines assigned to the activities.

Automatic removal from the machine park consists of two steps. 1:

1. select machine park resources

2. select activities

To automatically remove machinery from the activities, please follow these steps:

• Select the menu item Project > Machine > Remove the machinery from activities.

The dialogue box Machine deduction - Step 1 of 2: Choice of machinery opens.
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The list includes all the machines you can deduct from activities by selecting them in Step 1.

Machines are grouped together in teams, while machines not being part of a team are shown at the lower end of the list.

• Machine group-machine type - to which type of machine does the machine belong.

• Costs - Operating costs per hour.

• Select the check boxes by the machines in the No. column that you want to deduct from activities. You may also
click on the button Select all.

• Click on the button Continue. The dialogue box Machinery deduction - Step 2 of 2: Selection of activities
opens.
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This list shows you all the activities of the project or portfolio.

• The activities offered for selection reflect the structure of the project.

• Click on the check box for the activity from which you want to subtract the machines. You may also click on the
button Select all.

• Click on the button Finish.

5.4.5 Identify roles from the employyes assignation

If you have assigned employees to activities without assigning roles before this, you can identify the required roles from
the employee assignation.

In order to identify roles from employee assignation, do as follows:

• Select the menu item Project > Assistant > Employee > Identify roles from the employee assignation.

The dialogue box Identify roles from employee assignation - Step 1 of 1: Activities selection opens.
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It lists all activities you can select from.

• Mark the check boxes of the activities you want to select in the column Number.

• Click on the button Finish.

Note:

• You can click on the button Select all activities to mark all activities at a time.

5.4.6 Identify machine types from machine allocation

If you have allocated machines to activities without having previously allocated machine types, you can identify the
required machine types from the machine allocation.

In order to identify machine types from machine allocation, do as follows:

• Select the menu item Project > Assistant > Employee> Machine > Identify machine types from machine alloca-
tion*.
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The dialogue box Identify machine types from machine allocation - Step 1 of 1: Selection of activities opens.

It lists all activities you can select from.

• Mark the check boxes of the activities in the column Number you want to select.

• Click on the button Finish.

Note:

• You can click on the button Select all activities to mark all activities at a time.
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5.5 Synchronize resources

5.5.1 Shift to resource pool

It may be that the resources used in a project differ from those in the resource pool file, because project resources are
saved with the project. In this case, you can shift the project resources to the resource pool.

In order to align the resources, do as follows: Select the menu item Project > Project resource > to Resource pool

The dialogue Choose between project resources and resource pool will open if there are differences in resources.
The first row shows the entries from the resource pool, the second row - from the project resources.
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• Take a minute to decide which of the following options you want to
use for your work.

– Choose the option Use resource pool to use the resource pool.

– Choose the option Replace project resources with resource pool (per code) to replace the differing
project resources data with those of the resource pool.

– Choose the option Manual selection of resources to select manually for each deviating item.

• Click on the button OK.

Note:
• In selecting resources manually, the dialogue Manual selection of resources opens in the next step. For each of

the resource items you need to enter manually what you want to do with the differing resources.

5.5.2 Manual selection of calendar

In case of differing calendars in project resources and resource pool, you can use this function to define which calendars
you want to use in which ways.

The list of project resources contains the calendars (with deviations) used in a project. In the list of resource pools -
the calendar defined in the resource pool.
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In order to align the project calendar with the resource pool, do as follows:

• In the table Project resources mark the calendar you want to align.

• Click on one of the following buttons:

– Click on the button Use resource pool, if you want to use the resource pool calendar.

Note: this button is active only when you have selected an item for the resource pool.

– Click on the button Add to resource pool to add the project calendar to the resource pool.

– Click on the button Delete from all project activities to delete the project calendar.

• If necessary, switch to another tab to align the resources.

• Click on the button OK.

5.5.3 Manual selection of roles

In case of project resources differing from the resource pool, you can use this function to define which resource you
want to use in which ways.

The list of project resources contains the resources (with deviations) used in a project. The list of the resource pool
contains the resources saved in the resource pool (the program filters automatically the resources that match with the
project resources and the resource pool in the field Filter).
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In order to align manually the project roles with the roles contained in the resource pool file, do as follows:

• In the table Project resources mark the role you want to align.

• Click on one of the following buttons:

– Click on the button Use resource pool if you want to use the resource pool roles.

Note: this button is active only when you have selected an item for the resource pool.

– Click on the button Replace resource pool to replace the resource pool role with the project resource role.

Note: this button is active only when the allocation of a resource pool to the project resource via the code
has been successful.

– Click on the button Add to resource pool to add the project resource to the resource pool (the group
properties are entered in the existing group, but not in the group name of the project resource).

Note: this button is active only when you have selected a group in the table Resource pool.

– Click on the button Add to a new group in the resource pool to add the project resource and the group
name to the new group in the resource pool.

– Click on the button Delete from all project activities to delete the project resource.

• If necessary, switch to another tab to align the resources.

• Click on the button OK.
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5.5.4 Manual selection of teams

In case of project resources differing from the resource pool, you can use this function to define which resource you
want to use in which ways.

The list of project resources contains the resources (with deviations) used in a project. The list of the resource pool
contains the resources saved in the resource pool (the program filters automatically the resources that match with the
project resources and the resource pool in the field Filter).

In order to align manually the project teams with the teams contained in the resource pool file, do as follows:

• In the table Project resources mark the team you want to align.

• Click on one of the following buttons:

– Click on the button Use resource pool if you want to use the resource pool team.

Note: this button is active only when you have selected an item for the resource pool.

– Click on the button Replace resource pool to replace the resource pool team with the project resource
team.

Note: this button is active only when the allocation of a resource pool to the project resource via the code
has been successful.

– Click on the button Add to resource pool to add the project resource to the resource pool (the group
properties are entered in the existing group, but not in the group name of the project resource).

Note: this button is active only when you have selected a group in the table Resource pool.
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– Click on the button Add to a new group in the resource pool to add the project resource and the group
name to the new group in the resource pool.

– Click on the button Delete from all project activities to delete the project resource.

• If necessary, switch to another tab to align the resources.

• Click on the button OK.

5.5.5 Manual selection of employees

In case of project resources differing from the resource pool, you can use this function to define which resource you
want to use in which ways.

The list of project resources contains the resources (with deviations) used in a project. The list of the resource pool
contains the resources saved in the resource pool (the program filters automatically the resources that match with the
project resources and the resource pool in the field Filter).

In order to align manually the project employees with the employees contained in the resource pool file, do as follows:

• In the table Project resources mark the employee you want to align.

• Click on one of the following buttons:

– Click on the button Use resource pool if you want to use the resource pool employee.

Note: this button is active only when you have selected an item for the resource pool.

– Click on the button Replace resource pool to replace the resource pool employee with the project resource
employee.
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Note: this button is active only when the allocation of a resource pool to the project resource via the code
has been successful.

– Click on the button Add to resource pool to add the project resource to the resource pool (the group
properties are entered in the existing group, but not in the group name of the project resource).

Note: this button is active only when you have selected a group in the table Resource pool.

– Click on the button Add to a new group in the resource pool to add the project resource and the group
name to the new group in the resource pool.

– Click on the button Delete from all project activities to delete the project resource.

• If necessary, switch to another tab to align the resources.

• Click on the button OK.

5.5.6 Manual selection of materials

In case of project resources differing from the resource pool, you can use this function to define which resource you
want to use in which ways.

The list of project resources contains the resources (with deviations) used in a project. The list of the resource pool
contains the resources saved in the resource pool (the program filters automatically the resources that match with the
project resources and the resource pool in the field Filter).

In order to align manually the project employees with the materials contained in the resource pool file, do as follows:

• In the table Project resources mark the material you want to align.
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• Click on one of the following buttons:

– Click on the button Use resource pool if you want to use the resource pool material.

Note: this button is active only when you have selected an item for the resource pool.

– Click on the button Replace resource pool to replace the resource pool material with the project resource
material.

Note: this button is active only when the allocation of a resource pool to the project resource via the code
has been successful.

– Click on the button Add to resource pool to add the project resource to the resource pool (the group
properties are entered in the existing group, but not in the group name of the project resource).

Note: this button is active only when you have selected a group in the table Resource pool.

– Click on the button Add to a new group in the resource pool to add the project resource and the group
name to the new group in the resource pool.

– Click on the button Delete from all project activities to delete the project resource.

• If necessary, switch to another tab to align the resources.

• Click on the button OK.

5.5.7 Manual selection of machine types

In case of project resources differing from the resource pool, you can use this function to define which resource you
want to use in which ways.

The list of project resources contains the resources (with deviations) used in a project. The list of the resource pool
contains the resources saved in the resource pool (the program filters automatically the resources that match with the
project resources and the resource pool in the field Filter).
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In order to align manually the project employees with the machines contained in the resource pool file, do as follows:

• In the table Project resources mark the machine types you want to align.

• Click on one of the following buttons:

– Click on the button Use resource pool if you want to use the resource pool machine types.

Note: this button is active only when you have selected an item for the resource pool.

– Click on the button Replace resource pool to replace the resource pool machine type with the project
resource machine type.

Note: this button is active only when the allocation of a resource pool to the project resource via the code
has been successful.

– Click on the button Add to resource pool to add the project resource to the resource pool (the group
properties are entered in the existing group, but not in the group name of the project resource).

Note: this button is active only when you have selected a group in the table Resource pool.

– Click on the button Add to a new group in the resource pool to add the project resource and the group
name to the new group in the resource pool.

– Click on the button Delete from all project activities to delete the project resource.

• If necessary, switch to another tab to align the resources.

• Click on the button OK.
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5.5.8 Manual selection of machinery

In case of project resources differing from the resource pool, you can use this function to define which resource you
want to use in which ways.

The list of project resources contains the resources (with deviations) used in a project. The list of the resource pool
contains the resources saved in the resource pool (the program filters automatically the resources that match with the
project resources and the resource pool in the field Filter).

In order to align manually the project machines with the machines contained in the resource pool file, do as follows:

• In the table Project resources mark the machines you want to align.

• Click on one of the following buttons:

– Click on the button Use resource pool if you want to use the resource pool machine.

Note: this button is active only when you have selected an item for the resource pool.

– Click on the button Replace resource pool to replace the resource pool machine with the project resource
machine.

Note: this button is active only when the allocation of a resource pool to the project resource via the code
has been successful.

– Click on the button Add to resource pool to add the project resource to the resource pool (the group
properties are entered in the existing group, but not in the group name of the project resource).

Note: this button is active only when you have selected a group in the table Resource pool.
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– Click on the button Add to a new group in the resource pool to add the project resource and the group
name to the new group in the resource pool.

– Click on the button Delete from all project activities to delete the project resource.

• If necessary, switch to another tab to align the resources.

• Click on the button OK.

5.5.9 Manual selection of project category

In case of project resources differing from the resource pool, you can use this function to define which resource you
want to use in which ways.

The list of project resources contains the resources (with deviations) used in a project. The list of the resource pool
contains the project categories saved in the resource pool (the program filters automatically the resources that match
with the project resources and the resource pool in the field Filter).

In order to align manually the project categories with the categories contained in the resource pool file, do as follows:

• In the table Project resources mark the category you want to align.

• Click on one of the following buttons:

– Click on the button Use resource pool if you want to use the resource pool categories.

Note: this button is active only when you have selected an item for the resource pool.

– Click on the button Replace resource pool to replace the resource pool category with the project resource
category.
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Note: this button is active only when the allocation of a resource pool to the project resource via the code
has been successful.

– Click on the button Add to resource pool to add the project resource to the resource pool (the group
properties are entered in the existing group, but not in the group name of the project resource).

Note: this button is active only when you have selected a group in the table Resource pool.

– Click on the button Add to a new group in the resource pool to add the project resource and the group
name to the new group in the resource pool.

– Click on the button Delete from all project activities to delete the project resource.

• If necessary, switch to another tab to align the resources.

• Click on the button OK.

5.5.10 Manual selection of project status

In case of project resources differing from the resource pool, you can use this function to define which resource you
want to use in which ways.

The list of project resources contains the resources (with deviations) used in a project. The list of the resource pool
contains the resources saved in the resource pool (the program filters automatically the resources that match with the
project resources and the resource pool in the field Filter).

In order to align manually the project status with the status contained in the resource pool file, do as follows:

• In the table Project resources mark the status you want to align.
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• Click on one of the following buttons:

– Click on the button Use resource pool if you want to use the resource pool status.

Note: this button is active only when you have selected an item for the resource pool.

– Click on the button Replace resource pool to replace the resource pool status with the project resource
status.

Note: this button is active only when the allocation of a resource pool to the project resource via the code
has been successful.

– Click on the button Add to resource pool to add the project resource to the resource pool (the group
properties are entered in the existing group, but not in the group name of the project resource).

Note: this button is active only when you have selected a group in the table Resource pool.

– Click on the button Add to a new group in the resource pool to add the project resource and the group
name to the new group in the resource pool.

– Click on the button Delete from all project activities to delete the project resource.

• If necessary, switch to another tab to align the resources.

• Click on the button OK.

5.5.11 Manual selection of project clients

..index:: Synchronise project clients, Project client difference

In case of differences between the project resources and the resource pool you can determine here which resource is to
be used and how.

In the list of project resources, the resources contained in the project (with deviations) are displayed. In the list of the
resource pool the resources stored in the resource pool (the programme automatically filters the resources in the project
and resource pool in the resource pool in the Filter field).
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To manually match the project clients with the employees contained in the resource pool file manually with the em-
ployees contained in the resource pool file, please proceed as follows proceed as follows:

1. mark the client in the Project Resources table, you want to match.

2. click on one of the following buttons:

1. click the Use Resource Pool button, if you want to use the resource pool project client. Note: This button
is only enabled if you have selected a position in the resource pool.

2. Click the Replace Resource Pool button to replace the resource pool project client with the resource pool
project client. Note: this button is only enabled if an assignment of the resource pool with the project
resource via the code is successful.

3. click the Add to Resource Pool button, to add the project resource to the resource pool (the group properties
are the group properties are added to the existing group but not the group name of the project resource).
Note: This button is only enabled if a group is activated if a group is selected in the Resource Pool table.

4. Click the Add to resource pool in a new group button to add the project resource. to add the project
resource and group name to the resource pool in a new group.

5. Click the Delete from all project tasks button to delete the project resource.

3. If necessary, switch to another tab to match the corresponding resources.

4. Click on the OK button.
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CHAPTER

SIX

PROJECT VIEWS

6.1 Project views

Rillsoft Project provides about 12 views. You can toggle between the different views doing the following:

• Select the menu item Start and click on the view name in the tab Views.

Views on / off

Which of the project views do you want to have on display in the tab
In order to define which of the project views should be shown in the tab, do as follows:

• Select the menu item File > Options > Extended.
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• Mark the check box of the views you are interested in the block Views.
• Click OK.

Customize tabs in properties window
In the Activitiy properties area, you can specify which tabs should be visible in the process properties window.
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In the Project/sub-project properties area, you can specify which tabs should be visible in the project/sub-project
properties window.

In the Conflict properties area, you can specify which tabs should be visible in the conflict properties window.

6.2 Gantt chart

Application of Gantt charts:
• Visualisation of the project scheduling.

• Visualisation of the project structure.

• Visualisation of the contingency reserve.
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• Quick access to the properties of activities and subprojects.

You can use the Gantt chart for to do the following:
• Create and edit activities.

• Link activities.

• Create and edit subprojects.

• Edit the project structure.

• Change the timescale.

• Check contingency reserves.

• Check resource utilization by means of filter settings.

Context menu in the Gantt chart
For the table of activities
Mark a row (activity or subproject) in the table of activities. Once you have marked an activity, you can do as follows:

• Cut – cut the marked activity

• Copy – copy the marked activity

• Customize previous activity the latest start time – shift all activities that are scheduled for an earlier time than
the marked activity to the latest possible start date

• Customize successor activity the earliest start time – shift all activities that are scheduled for a later time than
the marked activity to the earliest possible start date

• Completed – enter the completion percentage of a marked activity

• Split – split the marked activity into several activities

• Incoming/Outbound link delete – delete the links of the marked activity

In a marked subproject you can do the following activities:
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• Cut – cut the marked subproject

• Copy – copy the marked subproject

• Show detail – display up to any outline level of the marked subproject detail

• Accept the start and finish dates of activities – accept the start date of the first activity and the end date of the
last activity for the subproject start and the end of subproject

• Earliest start date – this command is active only for subprojects with fixed start and finish dates and shifts all
activities in the subproject to the earliest possible start dates.

• Latest start date – this command is active only for subprojects with fixed start and finish dates and shifts all
activities in the subproject to the latest possible start dates.

• Move delayed activities to cutoff day – if the project controlling detects that activities are still not 100% com-
pleted, you can shift these activities to the deadline and so update the project’s status.

• Optimize resource utilization – most effective resource allocation, so as to avoid excess and shortfall within
the prescribed period

For the chart area

In the chart area you can mark an activity / subproject and do the following:
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• Paste – insert marked acrtivities / subprojects into a project

• Select all – mark all activities and subprojects: If activities are subordinated to a subproject, only the subproject
will be marked in the chart.

• New activity - create a new activity at the position pointed to by the cursor

• New activity from template file - insert an already saved activity from template file at the position pointed to
by the cursor

• New activity from Rillsoft Integration Server template - insert an already saved activity from Rillsoft Integra-
tion Server template at the position pointed to by the cursor. Only for the solution with interface to the Rillsoft
Integration Server

• New subproject - create a new subproject at the position pointed to by the cursor

• New subproject from template file - insert an already saved subproject from template file at the position pointed
to by the cursor

• New subproject from Rillsoft Integration Server template - insert an already saved subproject from Rillsoft
Integration Server template at the position pointed to by the cursor. Only for the solution with interface to the
Rillsoft Integration Server

6.3 Variance analysis

Variance analysis view shows you the difference between the current project plan and one of the baselines according
to the following criteria:

• Time

• Effort

• Cost

Application of variance analysis:
• Visualisation of the difference between target and actual.

• Detailed analysis of all parameter deviations.

You can use the variance analysis to do the following:
• Edit activities and subprojects from the actual plan.

• Change the timescale.

Context menu in the Variance analysis view
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• Select baseline – select a project state saved previously as a baseline for comparison.

• Show progress line over start date – visualize the schedule deviations between a project state and selected
baseline related to start dates.

• Show progress line over finish date – visualize the schedule deviations between a project state and selected
baseline related to finish dates.

• Show only difference – show only activities/projects, where there is the time shift between target and actual.

6.4 Variance analysis time

Variance analysis time shows you the temporal difference between the current project plan and one of the baselines.

Click on Start > Variance analysis > Time

Time difference
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Application of Variance analysis time:
• Visualization of the temporal difference between target and actual.

• Graphical representation of schedule deviations.

• Rapid detection of time deviations from the plan and fact by means of a progress line.

Note:
• The first row lists the properties of the scheduled activities and subprojects, while the second row lists the prop-

erties of the required activities and subprojects. Parameter deviating from the baseline are marked in yellow.

6.5 Variance analysis effort

Variance analysis effort shows you the difference between a current effort and the effort saved in a baseline.

Click on Start > Variance analysis > Effort

Effort difference
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Application of Variance analysis effort:
• Visualization of the difference between target effort and actual effort in the time scale.

6.6 Variance analysis cost

Variance analysis cost shows you the difference between current costs and the costs saved in a baseline

Click on Start > Variance analysis > Cost

Cost difference
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Application of Variance analysis cost:
• Visualization of the difference between target costs and actual costs in the time scale.

6.7 Variance analysis activity properties

If you click on a row in the table at a Variance analysis view, you can see the differences between the current state of
the activities and a state saved in the base plan in the properties window.
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These differences can be tracked on the following tabs:

• General

• Costs

• Roles

• Employee

• Material

• Machine type

• Machinery

General

Here are the deviations and a summed difference between planned and current values of an activities for

• start and finish dates

• the effort

• the duration

can be seen.
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Costs:

On the Costs tab you can see how large the target-actual deviations are for the resource costs.

Roles

Here you get an exact comparison between planned and actual roll requirements in one activities.

Employee

Which staff members were originally scheduled and which are currently assigned to an activities can be seen in the
Employee tab.

Material

Here you get an exact comparison between planned and actual material consumption in one activities.

Machine type
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Here you get an exact comparison between planned and actual machine type requirements in one activities.

Machinery

Here you get an exact comparison between planned and actual machine requirements in one activities.

6.8 Variance analysis of subproject properties

If you click on a row in a Variance analysis view in the table, you can have the differences between the current state of
a subproject and a state saved in the base plan shown in the properties window.
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These deviations can be tracked on the following tabs:

• General

• Costs

• Shared machine types

• Shared machinery

General

Here are the deviations and a summed difference between planned and current values of a sub-project for

• start and end dates
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• the effort

• the duration

can be seen.

Costs

On the Costs tab you can see how large the target-actual deviations are for the resource costs.

Shared machine types

Here you get an accurate comparison between planned and actual needs for common machine types in a sub-project.

Shared machinery

Here you get an exact comparison between planned and actual needs for common machinery in a sub-project.
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6.9 Network diagram

Application of the network diagram:

• Visualisation of the technological structure of the project.

You can use the network diagram to do the following:
• Create and edit activities.

• Link activities.

• Create and edit subprojects.

Context menu in the Network diagram view
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In the subproject area you can do the following activities:

• Cut – cut the marked subproject

• Copy – copy the marked subproject

• Show detail – display up to any outline level of the marked subproject detail

• Hide detail – hide up to any outline level of the marked subproject detail

• Accept the start and finish dates of activities – accept the start date of the first activity and the end date of the
last activity for the subproject start and the end of subproject

• Earliest start date – this command is active only for subprojects with fixed start and finish dates and shifts all
activities in the subproject to the earliest possible start dates.

• Latest start date – this command is active only for subprojects with fixed start and finish dates and shifts all
activities in the subproject to the latest possible start dates.

• Move delayed activities to cutoff day – if the project controlling detects that activities are still not 100% com-
pleted, you can shift these activities to the deadline and so update the project’s status.

• Optimize resource utilization – most effective resource allocation, so as to avoid excess and shortfall within
the prescribed period

For the chart area
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In the chart area you can mark an activity / subproject and do the following:

• Paste – insert marked acrtivities / subprojects into a project

• Select all – mark all activities and subprojects: If activities are subordinated to a subproject, only the subproject
will be marked in the chart.

• New activity - create a new activity at the position pointed to by the cursor

• New activity from template file - insert an already saved activity from template file at the position pointed to
by the cursor

• New activity from Rillsoft Integration Server template - insert an already saved activity from Rillsoft Integra-
tion Server template at the position pointed to by the cursor. Only for the solution with interface to the Rillsoft
Integration Server

In the subproject area, you can do the following:

• New subproject - create a new subproject at the position pointed to by the cursor

• New subproject from template file - insert an already saved subproject from template file at the position pointed
to by the cursor

• New subproject from Rillsoft Integration Server template - insert an already saved subproject from Rillsoft
Integration Server template at the position pointed to by the cursor. Only for the solution with interface to the
Rillsoft Integration Server
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6.10 Gantt-network chart

Application of the Gantt-network chart:
• Visualisation of time scheduling and the technological structure of the project.

You can use the Gantt-network chart to do the following:
• Create and edit activities.

• Link activities.

• Create and edit subprojects.

• Edit the technological structure.

Context menu in the Gantt-network chart view
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In the subproject area you can do the following activities:

• Cut – cut the marked subproject

• Copy – copy the marked subproject

• Show detail – display up to any outline level of the marked subproject detail

• Hide detail – hide up to any outline level of the marked subproject detail

• Accept the start and finish dates of activities – accept the start date of the first activity and the end date of the
last activity for the subproject start and the end of subproject

• Earliest start date – this command is active only for subprojects with fixed start and finish dates and shifts all
activities in the subproject to the earliest possible start dates.

• Latest start date – this command is active only for subprojects with fixed start and finish dates and shifts all
activities in the subproject to the latest possible start dates.

• Move delayed activities to cutoff day – if the project controlling detects that activities are still not 100% com-
pleted, you can shift these activities to the deadline and so update the project’s status.

• Optimize resource utilization – most effective resource allocation, so as to avoid excess and shortfall within
the prescribed period

For the chart area
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In the chart area you can mark an activity / subproject and do the following:

• Paste – insert marked acrtivities / subprojects into a project

• Select all – mark all activities and subprojects: If activities are subordinated to a subproject, only the subproject
will be marked in the chart

• New activity - create a new activity at the position pointed to by the cursor

• New activity from template file - insert an already saved activity from template file at the position pointed to
by the cursor

• New activity from Rillsoft Integration Server template - insert an already saved activity from Rillsoft Integra-
tion Server template at the position pointed to by the cursor. Only for the solution with interface to the Rillsoft
Integration Server

• New subproject - create a new subproject at the position pointed to by the cursor

• New subproject from template file - insert an already saved subproject from template file at the position pointed
to by the cursor

• New subproject from Rillsoft Integration Server template - insert an already saved subproject from Rillsoft
Integration Server template at the position pointed to by the cursor. Only for the solution with interface to the
Rillsoft Integration Server

6.11 Role

You can structure role usage by clicking the menu item Start > Outline > Structure using the following criteria:

• Role -> Project

• Project -> Role
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Applications for the Role usage view:
• Display of the project’s demand for roles in the project.

• Ressource allocation from the perspective of roles.

• Calculation of the usage of every single role.

• Calculation of the total efforts and total costs of every single role.

• Calculation of the FTE of every single role.

• Visualisation of the roles allocation in activities.

You can use the Role usage view for the following:
• Assign selected activities to a role.

• Analyse the role usage by means of filter settings.

• Change the timescale.

• Quick access to the resource pool.

Additional columns in the table
To switch on additional columns in the table, click the Tab format for a selected view.
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Context menu in the Role usage view

• Show maximum usage per unit of the time – the maximum required number of personnel resources for each
of the roles / qualifications per day, week, etc.

• Show average usage per unit of the time – the average required number of personnel resources for each of the
roles / qualifications per day, week, etc.

• Show effort per unit of the time – planned effort in employee hours (or employee days, respectively) per day,
week, etc.
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6.12 Role usage with effort

Role usage with effort representation instead of task bars in time scale.

6.13 Role usage and FTE

Role usage and Full Time Equivalent in the timescale.
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To calculate the Full Time Equivalent, set the annual working time per employee in the programm environment.

File > Options > General > Annual working time per employee
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6.14 Project-specific role

You can structure role usage by clicking the menu item Start > Outline > Structure using the following criteria:

• Role -> Project

• Project -> Role

Applications for the Project-specific Role usage view:
• Display of the project’s demand for resources in the form of roles for a project.

• Resource allocation from the perspective of roles.

• Project-specific calculation of the usage of every single role.

• Project-specific calculation of the total efforts and total costs of every single role.

• Visualisation of the roles assignation in activities.

You can use the Project-specific Role usage view for the following:
• Assign selected activities to a role.

• Analyse the role usage for a project by means of filter settings.

• Change the timescale.

• Quick access to the resource pool.
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Context menu in the Role usage view

• Show maximum usage per unit of the time – the maximum required number of personnel resources for each
of the roles / qualifications per day, week, etc.

• Show average usage per unit of the time – the average required number of personnel resources for each of the
roles / qualifications per day, week, etc.

• Show effort per unit of the time – planned effort in employee hours (or employee days, respectively) per day,
week, etc.

6.15 Team

You can structure team usage by clicking the menu item Start > Outline > Structure using the following criteria:

• Team -> Project

• Project -> Team
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Application of the Team usage view:

• Display of the project’s demand for resources in the form of teams.

• Resource allocation from the perspective of teams.

• Calculation of the usage for every single team.

• Calculation of the total efforts and total costs of every single team.

• Visualisation of the teams assignation to activities.

You can use the Team usage view for the following:
• Assign selected activities to a team.

• Analyse the team usage by means of filter settings.

• Change the timescale.

• Quick access to the resource pool.

• View additional resource chart or break-even chart.

Context menu in the Team usage view

• Show maximum usage per unit of the time – the maximum required number of personnel resources for each
of the work groups / teams per day, week, etc.

• Show average usage per unit of the time – the average required number of team resources / teams per day,
week, etc.
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• Show effort per unit of the time – planned effort in employee hours (or employee days, respectively) per day,
week, etc.

6.16 Project-specific team

You can structure team usage by clicking the menu item Start > Outline > Structure using the following criteria:

• Team -> Project

• Project -> Team

Application of the Project-specific team usage view:

• Display of the project’s demand for resources in the form of teams for a project.

• Resource allocation from the perspective of teams.

• Project-specific calculation of the usage for every single team.

• Project-specific calculation of the total efforts and total costs of every single team.

• Project-specific visualisation of the teams assignation to activities for a project.

You can use the Project-specific team usage view for the following:
• Assign selected activities to a team.
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• Analyse the team usage for a project by means of filter settings.

• Change the timescale.

• Quick access to the resource pool.

Context menu in the Project-specific team usage view

• Show maximum usage per unit of the time – the maximum required number of personnel resources for each
of the work groups / teams per day, week, etc.

• Show average usage per unit of the time – the average required number of team resources / teams per day,
week, etc.

• Show effort per unit of the time – planned effort in employee hours (or employee days, respectively) per day,
week, etc.

6.17 Employee workload

You can structure employee workload by clicking the menu item Start > Outline > Structure using the following
criteria:

6.17. Employee workload 235



Rillsoft Project, Release 9

Applications for the Employee workload view:
• Display of the project’s demand for resources in the form of employees in the project.

• Resource allocation from the perspective of employees.

• Calculation of the workload of every single employee.

• Calculation of the total efforts and total costs of every single employee.

• Visualisation of the employees assignation to activities.

You can use the Employee workload view for the following:
• Assign selected activities to an employee.

• Analyse the employee workload by means of filter settings.

• Change the timescale.

• Quick access to the resource pool.

• Check the calendar of employees.

Context menu in the Employee workload view

• Show maximun workload per unit of the time – The maximum required number of personnel resources per
day, week, etc.
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• Show average workload per unit of the time – The average required number of personnel resources per day,
week, etc.

• Show effort per unit of the time – Planned effort in employee hours (or employee days, respectively) per day,
week, etc.

• Show percent workload per unit of the time – Shows the weekly total workload of employees in percent instead
in employee hours / employee days.

6.18 Employee workload with an additional Gantt chart

As with other resource views you can add as an additional view the Gantt Chart by clicking the menu item Start >
Additional view > Gantt chart.

It helps not only to control resource utilization but also to keep the time project progress constantly in mind.

All activities usual for resource views are available here now.
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6.19 Project-specific employee workload

You can structure employee workload by clicking the menu item Start > Outline > Structure using the following
criteria:

Applications for the Project-specific employee workload view:
• Project-specific display of the project’s demand for resources in the form of employees.

• Resource allocation from the perspective of employees.
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• Project-specific calculation of the workload of every single employee.

• Project-specific calculation of the total efforts and total costs of every single employee.

• Visualisation of the employees assignation to activities.

You can use the Project-specific employee workload view for the following:
• Assign selected activities to an employee.

• Analyse the employees workload for each of the projects by means of filter settings.

• Change the timescale.

• Quick access to the resource pool.

• Check the calendar of employees.

Context menu in the Project-specific employee workload view

• Show maximun workload per unit of the time – The maximum required number of personnel resources per
day, week, etc.

• Show average workload per unit of the time – The average required number of personnel resources per day,
week, etc.

• Show effort per unit of the time – Planned effort in employee hours (or employee days, respectively) per day,
week, etc.

• Show percent workload per unit of the time – Shows the weekly total workload of employees in percent instead
in employee hours / employee days.

6.20 Timesheets tab on the employee view

Here you can display information about the hours worked for a personnel resource.

Prerequisite You or assigned employees can only enter the confirmations in the Rillsoft Integration Server interface.

Activate the tab Timesheets in the activities properties window.

Activities
All activities assigned to the employee are listed here.

Name Name of the assigned activities

Target shows the effort scheduled in the activities for this employee

Actual shows how much of the planned effort the employee has already spent on the activities

Open - shows open effort in the activities for this employee

Notes Notes

Whether the effort is displayed in person-hours or person-days depends on the project settings.

Timesheets
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Here you can see for a activitiy selected on the left how the employee has worked through the task on a daily basis.

Calendar week in which calendar week did the employee work for the activities

Day on which day of the week the employee worked for the activities

Data Date

Target shows the effort planned for this employee on the day and for the activities

Actual shows how much of the planned effort the employee has already completed during the day

Shift Time of day
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6.21 Human Resource Capacity Leveling

If the scheduling of roles and machine types is completed, the Human Resource Capacity Leveling view helps you
to estimate whether there is sufficient personnel capacities to execute the project or where potential bottlenecks may
occur.

The Human Resource Capacity Leveling is determined by the number of employees, their qualifications, time of em-
ployment and workplace (project, subproject). The Human Resource Capacity Leveling shows not only the number
of the required hours and days for employees and roles, but also indicates excess and shortfall (supply minus demand
= contingency). Moreover, the Human Resource Capacity Leveling view helps you to detect employees that match
the requirements of the demand.

Employees whose employee hours / days are in boldface, have already been assigned to this activity. If they are displayed
in both boldface and red colour, you have an assignation conflict, which means that the employee has been assigned to
several activities at one time.

You can use the Human Resource Capacity Leveling view to do the following:

• Detect overloaded resources as well as the scale and cause of this event.

• View the working capacity for each of the resource role.

• Calculate the numbers of work hours that have been assigned to the individual employees.

• Determine the time the employee is available for additional assignments.
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• Assign recources optimally.

Context menu in the Human Resource Capacity Leveling view

6.22 Relative capacity requirements percent each role

Percentage per professional role
This option calculates the percentage by which a demand for an occupational role may have been met or undermet with
the available skilled labour.

The capacity utilisation per role is calculated using the formula:

(Actual capacity used/total capacity) x 100

The existing resource capacity is defined as the basis, i.e. how many person-days are available per role, for example, is
taken as 100%.

Percentage of all professional roles
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A percentage share of an occupational role is calculated in relation to a common need for all roles.

(Actual capacity used per roll/total capacity of all rolls) x 100

6.23 Human Resource Capacity Leveling with an additional Gantt
chart

As with other resource views, you can add as an additional view the Gantt Chart by clicking the menu item Start >
Additional view > Gantt chart.
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It helps not only to control a capacity alignment but also to keep the time project progress constantly in mind.

All activities usual for resource views are available here now.

6.24 Project-specific Human Resource Capacity Leveling

You can structure employee usage by menu item Start > Outline > Structure using the following criteria:
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You can use the **Project-specific Human Resource Capacity Leveling to do the following:**

• Detect overloaded resources as well as the scale and cause for this event.

• View the working capacity for each of the resource role per project.

• Calculate the numbers of work hours that have been assigned to the individual employees per project.

• Determine the time the employee is available for additional assignments.

Context menu in the Human Resource Capacity Leveling view

• Show maximum usage per unit of the time – The maximum required number of personnel resources for each
of the roles / qualifications per day, week, etc.

• Show average number per unit of the time - average required number of human resources per day,week, etc.

• Show effort per unit of the time – Planned effort in employee hours (or employee days, respectively) per day,
week, etc.
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6.25 Human Resource Capacity Leveling with additional resource
chart

As with other resource views you can add as an additional view the resource chart by clicking the menu item Start >
Additional view > Resource chart.

Additional resource chart contrasts the demand (blue and red bars) for each of the roles / qualifications to the capacity
(green line).

If you click on the required roles / qualification in the table, the chart shows the required number (per unit) of resources
as bars marked blue.

The green line shows the available number (per unit) of employees.

If the green line (supply of employees) is above the blue bar (demand for employees), there is an excess of employees.

However, if the green line runs across a blue bar, a red bar shows a shortfall of employees.
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6.26 Material requirement

You can structure material requirement by clicking the menu item Start > Outline > Structure using the following
criteria:

• Material -> Project

• Project -> Material

Applications for the Material requirement view:
• Display of the project’s demand for materials.

• Resource allocation from the perspective of resources.

• Calculation of the total efforts and total costs of every single material.

• Visualisation of the materials allocation to activities.

You can use the Material requirement view for the following:
• Assign selected activities to a material.

• Analyse the material requirements by means of filter settings.

• Change the timescale.

• Quick access to the resource pool.
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6.27 Machine types

You can structure machine types by clicking the menu item Start > Outline > Structure using the following criteria:

• Machine types -> Project

• Project -> Machine types

Applications for the Machine Types view:
• Display of the project’s demand for machine types.

• Ressource allocation from the perspective of machine types.

• Calculation of the usage for every single machine type.

• Calculation of the total efforts and total costs of every single machine type.

• Visualisation of the machine types allocation in activities.

You can use the Machine types view for the following:
• Assign selected activities to a machine type.

• Analyse the a machine type usage by means of filter settings.

• Change the timescale.

• Quick access to the resource pool.

248 Chapter 6. Project views



Rillsoft Project, Release 9

Context menu in the Machine types view
If you open the context menu in the Machine types row, the following commands appear:

• Show maximum usage per unit of the time – The maximum required number of machine resources for each
of the machine types / machine groups per day, week, etc.

• Show average usage per unit of the time – The average required number of machine type resources per day,
week, etc.

• Show effort per unit of the time – Planned effort in employee hours (or days, respectively) per day, week, etc.

If you open the context menu in the Activity row, the following commands are available:

• Share - the selected activity shares the machine type together with other activities.

• Use exclusively - the selected activity uses the machine type exclusively.

6.28 Machinery usage

You can structure Machinery usage by clicking the menu item Start > Outline > Structure using the following criteria:

• Machine -> Project

• Project -> Machine
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Applications for the Machinery Usage view:
• Display of the project’s demand for machines in the project.

• Ressource allocation from the perspective of machines.

• Calculation of the usage of every single machine.

• Calculation of the total efforts and total costs of every single machine.

• Visualisation of the machines allocation in activities.

You can use the Machinery Usage view for the following:
• Assign selected activities to a machine.

• Analyse the machine usage by means of filter settings.

• Change the timescale.

• Quick access to the resource pool.

Context menu in the Machinery Usage view
If you open the context menu in the Machine row, the following commands appear:

• Show maximum usage per unit of the time – the maximum required number of machine resources for each of
the machine groups - machine types per day, week, etc.

• Show average usage per unit of the time – the average required number of machine resources per day, week,
etc.

250 Chapter 6. Project views



Rillsoft Project, Release 9

• Show effort per unit of the time – planned effort in machine hours (or machine days, respectively) per day,
week, etc.

If you open the context menu in the Activity row, the following commands are available:

• Share - the selected activity shares the machine together with other activities.

• Use exclusively - the selected activity uses the machine exclusively.

6.29 Machine capacity planning

You can structure Machinery use by clicking the menu item Start > Outline > Structure using the following criteria:

• Machine types -> Machine

• Machine types -> Project -> Machine

• Project -> Machine types -> Machine

Applications for the Machine capacity planning view:
• Display of the project’s demand for machines in the project.

• Calculation of the usage of every single machine.

• Calculation of the total efforts and total costs of every single machine.
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• Visualisation of the machines allocation in activities.

You can use the Machine capacity planning view for the following:
• Analyse the machine usage by means of filter settings.

• Change the timescale.

• Quick access to the resource pool.

Context menu in the Machine capacity planning view

• Show maximum usage per unit of the time – the maximum required number of machine resources for each of
the roles / qualifications per day, week, etc.

• Show effort per unit of the time – planned effort in machine hours (or machine days, respectively) per day,
week, etc.

6.30 Machine capacity planning with additional resource chart

As with other resource views you can add as an additional view the resource chart by clicking the menu item Start >
Additional view > Resource chart.

252 Chapter 6. Project views



Rillsoft Project, Release 9

Additional resource chart contrasts the demand (blue and red bars) for each of the machine groups / machine types to
the capacity (green line).

If you click on the required machine group / machine type in the table, the chart shows the required number (per unit)
of resources as bars marked blue.

These show the sum of the machine capacity requirements (per unit, for example, a day, a week, a month, etc.). The
bars are displayed in blue, while the resource requirements do not exceed the available supply.

The green line shows the available number (per unit) of machines. If the green line (supply of machines) is above the
blue bar (demand for machines), there is an excess of machines.

However, if the green line runs across a blue bar, a red bar shows a shortfall of machines.

6.31 Customise format views

All views have a Format tab where numerous functions for view customisation are grouped together. Depending on
the format view, the available options may vary.

Data
Block Data provides the following functionality:

• Columns Adjust the column order in the task table
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• Sort Sort the sequence of tasks in the project according to various criteria such as start time, name, etc.

• Renumber Renumber the tasks and sub-projects after editing the plan.

• Excel Export the view to MS Excel, if necessary with several levels and columns displayed in the table.

Tooltips
pear as tooltips and/or warnings when you move the cursor over an operation bar.

The following tooltips are possible:

• Roles

• Employees

• User defined fields

• Notes & Links

• Other tooltips

You can switch on the following warnings:
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Progress line only for Variance analysis Time.

• Start dates a progress line is mapped in relation to the start dates of activities

• End dates a progress line is mapped in relation to the end dates of activities

Difference for Variance analysis of Effort and Costs
• Value the values from the baseline plan and the values from the current interim plan are shown

• Difference the values from the basic plan and a difference to the basic plan values are calculated
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Resource units
For the Employees Utilisation view, you can have the resource utilisation per time unit displayed in different variants:

• Maximum - maximum number of human resources required per day, week, etc.

• Average - average number of human resources required per day, week, etc.

• Effort - planned effort in person-hours or person-days per day, week, etc.

• Utilisation (Percentage) - enables the total utilisation of human resources by day or week to be displayed as a
percentage instead of person-hours/days.

If you display the resource units at the Role Utilisation View in FTE full-time equivalent, the FTE Full Time Equivalent
(FTE) option shows you the standard performance capability of a resource in a specific time period (e.g. 1 year) in a
company.

In the view Capacity Employee you can calculate a resource requirement either in resource units such as person-
hours/days or in percentages according to professional roles:

• Effort a required resource demand is compared with an available offer related to the project settings, e.g. person-
hours or person-days.

• Percentage per role shows to what percentage a demand for an occupational role is covered or undercovered
with existing personnel resources.
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• Percentage of all roles calculates the percentage of an occupational role in relation to a demand for all qualifi-
cations.

Show
This block contains the options that allow you to refine the graphical representation of the project.

For all views except the network diagram and Gantt network chart

• Project start shows a project start as an additional vertical line in the Gantt chart.

• Project end shows a project end as an additional vertical line in the Gantt chart

• Cutoff date shows a cutoff date as an additional vertical line in the Gantt chart

• Current date shows a period in the Gantt chart with a background colour where the current date is located

• Milestone in calendar Milestones are shown/hidden at the top of the calendar bar.

• Milestone in subproject/project Milestones are shown/hidden on a collapsed subproject bar.

• Non-working days key Designations for non-working days, e.g. U for holiday, are shown/hidden in the Gantt
chart.

• Reserve time shows earliest and latest possible operation items

• Critical path shows in red colour operations that belong to the critical path.

• Labels the labels are shown/hidden in the Gantt chart

• Links show/hide the links between operations

For all Resource views
• Milestone in resource line Milestones are shown/hidden on a resource line, provided that the resources are

assigned to the milestones.

• Total utilization shows the summed resource utilisation per view in the title area of the chart

• Activity chart the activities bars are displayed in resource views

• Activity value the effort values for the activities are displayed in resource views

• Employee the human resources can be seen in a capacity view

• Period shows the free time periods within which you can move the activities.
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For Employee view
• Shift calendar The shift calendars assigned to the employees are displayed with background colour.

For Variance analysis Time view

• Only difference only those activities and sub-projects are displayed that have a difference to the selected base
plan.

For Variance analysis of Effort and Costs view

• Only completed only the effort or cost values are compared for the activities where the work done, e.g. the
completed percentage or completed effort is higher than zero. If an activity is 100% complete, the current effort
or cost is compared with the planned values for the whole activity.

However, if a task is only partially completed, e.g. 50%, then the current 50% effort is compared to the planned 50%
effort of the task.

Group
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The option Activities in one row can make the graphical representation look compact. In doing so, it might be useful
to switch off the Labels from the Show block.

The option Group by employees is useful when a staff member may have several professional roles or belong to
different work groups and you want to map all his activities together.

6.32 User views

You can save the actual view with the saved unit of time, the filter and combinations with additional charts as a user
view, e.g. employee and gantt chart.

It allows you to create and edit your own views.

In order to create an user view, do as follows:

• set up a view with required settings such as time scale, filters, additional chart, etc.

• click Start > User views > Add.

• add a name for your view.

• click OK.

In order to display the view, click Start > User views > Show.

Manage the user views
You can change the names order of the saved views by clicking the menu item Start > User views > Manage.
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6.33 Additional resource chart

You can add resource chart as an additional view by clicking the menu item Start > Additional View > Resource
chart.

Application of the additional resource chart:
• Visualisation of the resource usage of a project.

• Analyse the resource usage by means of filter settings.

Selection by resource types
You can filter out additional resource chart using the following criteria:

You can open an additional resource chart in the following views:
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• Activity view

– Gantt chart

– Gantt-network chart

• Resource view

– Role

– Team

– Employee

– Machine types

– Machine

– Machine requirements

• Capacity view

– Employee

– Machine

6.34 Additional cost chart

You can add cost chart as an additional view by clicking the menu item Start > Additional View > Cost chart.
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Application of the additional cost chart:
• Visualisation of the target and actual costs.

• Analysis of the target and actual costs.

Selection by type of financing
You can filter out additional cost chart using the following criteria:

You can open an additional cost chart in the following views:

• Activity view

– Gantt chart

– Variance analysis

– Gantt-network chart

• Resource view

– Role

– Team

– Employee

– Machine types
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– Machine

– Material requirements

6.35 Additional gantt chart

You can add gantt chart as an additional view by clicking the menu item Start > Additional View > Gantt chart.

Application of the additional gantt chart:
• Visualisation of a project’s progress.

You can open an additional gantt chart in the following views:

• Resource view

– Role

– Team

– Employee

– Machine types

– Machine

– Material requirements

6.35. Additional gantt chart 263



Rillsoft Project, Release 9

• Capacity view

– Employee

– Machine

6.36 Filter

You can use the filter to define the information you want to display.

Determine filters
• Click on the menu Start > Edit > Filter

• Mark the according check box.

• Select the required resource from the drop down menu.

• Click on the button OK.
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The following filters are available:

Free text
A free-text filter applies to all views except the network/bar network plan and is suitable for filtering out according to
the following criteria:

• Activity/subproject names

• code

• User defined fields

• Notes

In addition, search criteria can be combined, such as Activity Name and Notes.
Structure filter or Project / subproject filter
Displays information about activities and resources for the selected subprojects only. You can set the Structure filter in
all views.

Time filter
Displays information about activities and resources for specific periods of time only.

Alternative You can set the time filter with the mouse by clicking the left button and selecting a start date and a finish
date.

You can set a report period filter in gantt chart, variance analysis and all resource views.

Hide completed activities
The filter hides already completed tasks and helps to exclude irrelevant information from project presentation.

It is suitable in the activities views such as the Gantt chart, resource views.

Note In capacity views allows this filter to take out the resources of completed activities and provide other tasks as
free capacities.

Show only overloaded resources
The filter helps to detect overloaded resources. You can use it in the Employee workload and Machinery.

Offer only planned resources for selection
If this check box is not marked, all resources in the resource pool will be available for selection. The activation of this
filter makes only those resources available for selection that have been already used in this subproject / project.
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This filter can be set in the views Role usage, Team utisage, Employee workload, Human resource capacity planning,
Material, Machine types, Machinery and Machine capacity planning.

Note In capacity views this filter refers to roles. I.e. switched on option displays only roles, which are already planned
in the project/portfolio. If the option is switched off, all the roles from the resource poolare listed in the capacity view.
Accordingly, the employee list below is changed.

Role filter
If resources are assigned to activities in the form of roles or employees, they can be included in the role filter.

You can set the role filter in the activities views such as the Gantt chart and Role usage.

Team filter
If resources are assigned to activities in the form of teams, they can be included in the team filter.

You can set the team filter in the activities views such as the Gantt chart and Team usage.

Employee filter
If resources are assigned to activities in the form of employees, they can be included in the employee filter.

You can set the employee filter in the activities views such as the Gantt chart, resource and capacity views and Employee
workload.

Material filter
If resources are allocated to activities in the form of materials, they can be included in the material filter.

You can set the material filter in the activities views such as the Gantt chart and Material requirements.

Machine type filter
If resources are allocated to activities in the form of machine types, they can be included in the machine type filter.

You can set the machine type filter in the activities views such as the Gantt chart and Machine types.

Machinery filter
If resources are allocated to activities in the form of machines, they can be included in the machinery filter.

You can set the machinery filter in the activities views such as the Gantt chart and Machinery.

Project Categories
When project categories are assigned to projects, they can be included in the project category filter and be used in the
portfolio.

You can set the project category filter on a Gantt chart, resource and capacity views.

Project Status
When project statuses are assigned to projects, they can be included in the project status filter and used in the portfolio.
project status filter and be used in the portfolio.

You can set the project status filter on a Gantt chart, resource and capacity views.

Project Clients
When project clients are assigned to projects, they can be included in the project client filter and be used in the portfolio.

You can set the project client filter on a Gantt chart, resource and capacity views.
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6.37 Search

With the help of the menu item Start > Edit > Search you can search the projects and portfolios for tasks/sub-projects
with specific information.

The Search dialogue box opens.

Here you can set the search criteria for the following fields:

• Task/sub-project name

• Code

• User defined fields

• Notes

In addition, the search criteria can be combined, e.g. task name and note.
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SEVEN

PROJECT PORTFOLIO

7.1 Project portfolio

A product portfolio includes several projects and allows:

• Cross-project capacity planning

• Optimal resource utilization between several projects

• Simulations

You can take all the current projects of the company in a portfolio together and / or add projects in several portfolios.

Requirement: Only the projects that share a common resource pool, may be included in the project portfolio.

All views from the Gantt chart to the resource chart are available for the project portfolio. In the project portfolio you
can run all the activities similar to a conventional project, that is, you can create activities, allocate resources, correct
processes or save outputs.

269



Rillsoft Project, Release 9

Note A new project can not be created in the portfolio. You should create a new project separately and then add a
portfolio.

7.2 New project portfolio

In order to open a new project portfolio, do as follows:

• Select the menu item File > Open new project portfolio.

• The dialogue window Portfolio Project selection appears.

• Click on the button Add Folder.

• Select the folder which contains the required projects.

• Click on the button OK.

Note the dialogue window Portfolio Project selection. It provides the projects that can be selected for the project
portfolio.

Note: Only projects that share a common resource pool can be included in the project portfolio.

If projects are not marked and have a red background in the To resource pool column, this indicates a difference
between project resources and the resource pool.

Include projects with project resources in the portfolio
Deviating projects being coloured grey can be added to the portfolio as follows:

• Automatic replacement of project resources
The option Replace deviating project resources by resource pool updates the project resources by
adding the resource pool at every opening of the portfolio.
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The view Variance analysis displays the changes in time of the projects graphically.

• Manual switching of project resource to resource pool
• In order to have the portfolio projects with significant differences in resources, they must be opened separately

and you can switch from the project resource to the resource pool by means of the menu item Project > Switch
> Resource pool.

Edit portfolio
You can use the following three buttons to do the following:

Select all – all projects from the list, that share a common resource pool, are included in the project portfolio. Select
none - all projects from the list are taken out from the project portfolio. Add a folder - search a new folder for projects
Add a file - add single projects to the list

Select the projects you want to add in the project portfolio. If you want to enter other projects in the list, click on the
appropriate button to add either a folder or file.

The projects shown in the list can be sorted according to the following parameters:
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• Project name

• Code

• Category

• Priority

• Status

• Start of project

• Finish of project

• File names

The selected order is then accepted by the project portfolio.

All views from the Gantt chart to break-even chart are available for the project portfolio. In the project portfolio you
can run all the activities similar to a conventional project, that is, you can create activities, allocate resources, correct
processes or store outputs.

7.3 New Project Portfolio in Rillsoft with Interface to the Rillsoft Inte-
gration Server

To create a project portfolio, please proceed as follows:

1. Select the menu item File > New > New project portfolio.

2. Right after the Rillsoft Integration Server Portfolio dialog, the Rillsoft Integration Server Portfolio Proper-
ties dialog window appears.
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3. Enter a name for the new portfolio in the Name field.

4. Filter is a free text field to delineate the information displayed below.

5. Select the directory where the required projects are located.

6. Mark the individual projects that should be included in the portfolio. You can also add projects from other
directories if necessary.

7. Then click the OK button.

The Rillsoft Integration Server Portfolio dialog window shows you a list of existing portfolios in the left table. The
newly created portfolio is marked in the list, and in the right table, you can review the content of the portfolio.
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From the Total projects column, you can see how many projects the portfolio contains.

The Available projects column indicates how many projects from the portfolio you are allowed to read.

If the Baselines load option is marked, the base plans of projects will also be loaded when opening the portfolio.
However, this can slow down the work with the portfolio.

By default, all available projects from the portfolio are marked, but you can remove the marking from individual projects
before opening the portfolio.

Moreover, you can open the selected projects read-only by marking them in the Read-Only column.

Note: Although you can add projects with resources differing from the resource pool to the portfolio, upon opening the
portfolio, a note will appear advising you to switch these projects to the resource pool with Project > Project resources
> Switch to resource pool.

7.4 Open a project portfolio

In order to open a project portfolio, do as follows:

• Select the menu item File > File > Open project portfolio.

• The dialogue window Open appears.

• Select the required file.

• Click on the button OK.

The dialogue window Project selection for portfolio appears. A list of projects for the project portfolio is shown.
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Note: Only projects that share a common resource pool can be included in the project portfolio.

If projects are coloured grey, it indicates a difference between project resources and the resource pool.

Include projects with project resources in the portfolio
Deviating projects being coloured grey can be added to the portfolio as follows:

• Automatic replacement of project resources.
The option Replace deviating project resources by resource pool updates the project resources by adding
the resource pool at every opening of the portfolio. The view Variance analysis displays the changes in
time of the projects graphically.

• Manual switching of project resource to resource pool.
In order to have the portfolio projects with significant differences in resources, they must be opened sepa-
rately and you can switch from the project resource to the resource pool by means of the menu item Project
> Switch > Resource pool.

Edit portfolio
You can use the following three buttons to do the following:
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Select all projects – all projects from the list, that share a common resource pool, are included in the project portfolio.
Take out all projects - all projects from the list are taken from the project portfolio out. Add a folder - search a new
folder for projects Add a file - add single projects to the list

Select the projects you want to add to the project portfolio. If you want to enter other projects in the list, click on the
appropriate button to add either a folder or a file.

Set the order of the project portfolio
The projects shown in the list can be sorted by the following parameters:

• Project name

• Code

• Category

• Priority

• Status

• Start of project

• Finish of project

• File names

The selected order is then accepted by the project portfolio.

All views from the Gantt chart to break-even chart are available for the project portfolio. In the project portfolio you
can run all the activities similar to a conventional project, that is, you can create activities, allocate resources, correct
processes or store outputs.

7.5 Open a project portfolio in Rillsoft with interface to Rillsoft Inte-
gration Server

In order to open a project portfolio, do as follows:

• Select the menu item File > Open > Rillsoft Integration Server > Project portfolio.

• The dialogue Rillsoft Integration Server - Portfolio appears.
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3. Left, all portfolios are listed with information about project number in the portfolio and number of projects that
are available for you, it is related to your access rights.

4. Right, you see all the projects from the selected portfolio. You can take out individual projects from the portfolio
for this time by deleting the marking of appropriate projects or all projects by click Select: All.

5. You can apply some projects read-only i.e. only to read in the portfolio, by selecting them in Read-Only column
or all projects by click Readonly: All.
You can see at once on a red background if any projects are locked as well.

6. Click on the button OK.

Note: Only projects that share a common resource pool can be included in the project portfolio.

If project resources are differrent from the resource pool, the message appears.
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In order to have the portfolio accepted projects with significant differences in resources, they must be opened separately
and you can switch from the project resource to the resource pool by means of the menu item Project > Switch >
Resource pool.
Locking

• Pessimistic – once a user edits something in the project, all other users can open the project only as a read-only
copy.

• Optimistic - each user can always edit the project.

The lock option is available only for the user, who also have the appropriate access rights.

Baselines load
Baseline slows the work with the portfolio. If you do not need a comparison with a baseline at the moment, you can
open portfolio without a baseline.

Set the order of the project in portfolio
The projects shown in the list can be sorted according to the following parameters:

• Project name

• Code

• Category

• Priority

• Status

• Start of project

• Finish of project

• File names

Click on the selected column in the title area, e.g. Start.
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The selected order is then accepted by the project portfolio.

Change portfolio properties
Click on the button Properties

If you want to add other projects to the list, click on the appropriate button to add either a folder or file.

7.6 Reload portfolio

If you are working in a multi-user environment, it may often be necessary to reload a portfolio where several people
are working on different projects at the same time in order to view their changes.

With the help of the menu item File > Reload Project > Portfolio you can reload the current portfolio.
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Alternatively, you can use a quick access.

Click the Reload icon on the Quick Access Toolbar.

Notes: If the Reload icon is not present, you can select Reload from the Customise Quick Access Toolbar menu item.
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7.7 Cross-project links

In the portfolio you can link several projects with each other. Important! This function is only included in Rillsoft
Project with Rillsoft Integration Server and links can only be edited in the portfolio.

In cross-project links, succeeding activities are shifted not automatically, but the program sets negative intervals instead.
By means of the menu item Project/Rillsoft Integration Server/Cross-project links, you can check these links and
obtain detailed information about them, such as occurring delays.

You can choose whether you want to accept only single or all of the changes you have made to these settings.
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The following information and options are available:

Move The calculated delay will be compensated by the approved delay when you click on the
check box.

Outgoing project / ac-
tivity

Displays outgoing projects/activities.

Incoming project / ac-
tivity

Displays incoming projects/activities.

Start Shows, where a link starts.
Finish Shows, where a link ends.
Reserve Shows the interval between the outgoing and incoming positions in absolute time.
Delay, Release Displays the value of the released interval.
Delay, Calculation Displays the value of the calculated interval.

Red background colouring signals that there is a discrepancy between the released and the calculated delay.

Set to automatic
Click this button if all calculated delays should be automatically aligned with the released delays.

Types of links
The following link types are at your disposal:
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Finish-Start the “from” activity must finish before the “to” activity can start
Start-Start the “from” activity must start before the “to” activity can start
Finish-Finish the “from” activity must finish before the “to” activity can finish
Start-Finish the “from” activity must start before the “to” activity can finish

Time intervals
Intervals can be defined in Project properties in relation to the time unit of the duration (such as hours or days). Intervals
can only be defined in absolute time (estimated duration including non-working time, such as: 10 hours or 2 days).

Intervals can have

• positive (such as: + 2 hours) or

• negative (such as: - 50% = overlapping)

signs.

Highlight link
Links can be highlighted by means of colour or boldface.

Create cross-project link
New cross-project links can be only created by Rillsoft Project with Rillsoft Integration Server in the portfolio. In order
to create a new cross-project link, do as follows:

• Choose the link type via the menu item Start > Insert > Link.

• Connect two activities by drawing your mouse from one activity of a
project to another activity from another project.

• If necessary, enter the delay (positive or negative) by which you want
to delay the “to” acticity depending on the selected link type.
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Note: If you do not enter any delay, the delay related to positions of outgoing and incoming activities is automatically
calculated.

• Click on the button OK.
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EIGHT

PROJECT CONTROLLING

8.1 Project controlling

Project controlling consists of the following:

• Entering information about the project progress

• Setting of cutoff date

• Analyse of ongoing and waiting activities

Enter information about the project progress
The updating of information about a selected activity can be accomplished by entering the activity’s percentage of
completion at regular intervals.

In order to enter the completed activity’s percentage, do as follows:

• Mark the activity you want to enter in the diagram.

• Activate the tab General in the window Activity properties.

• Enter the percentage in the field Completed.

• Click on the button OK.

Alternative 1: You can enter the completion percentage in the context menu of the activity.

Alternative 2: Select a task and click the menu item Start > Schedule >. . .
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Alternative 3: You can enter the completion percentage in the table of the Gantt chart in the columns Quantity, Effort
and Duration below Completed. - click on Gantt chart Format > Data > Columns and selectthe required columns.
- click on Gantt chart Format > Data > Columns and select Select the required columns.

• Enter eg., how much effort has been completed.
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Note: If there is a number of activities linked as Finish-Start, and if the successor has more than 0% in the field
Completed, its predecessor is set automatically to the value 100%.

Setting of cutoff date
A cutoff date is the point of time at which the percentages were entered last time. A cutoff date is determined by means
of a check mark (a small triangle in the upper part of the timescale).

Example: Gantt chart with determined cutoff date and percentages (black bar in activities).
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Analyse of ongoing and waiting activities
You can view the project information by clicking on the blank space in the window of the main project.

• Completed - Number of finished activities.

• Started - Number of started activities.

• Still not started - Number of activities that have not yet started.

• All - Number of all activities.

• Reserve - Difference in time between the finish date of the latest activity and the cutoff date of the project.

• Completed - Percentage of the project’s progress (is calculated only by means of the activities duration).

• Ongoing and waiting activities - This list shows detailed information about activities that have just started or
are ready to be started.

The column Difference shows the deviation between the actual progress of activities at the moment and at the cutoff
date (negative difference: delay / backlog, positive difference: gain of time).
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8.2 Add baseline

In order to add a baseline, do as follows:

• Select the menu item Project > Baseline > Add. The dialogue box Add baseline opens.

• Enter the name of the baseline in the field Name or accept the automatic name.

• Click on the button OK.

Note: You can save any number of baselines in the project. This allows you to document your changes in the project, on
the one hand, and provides you with the opportunity to analyse your project after its completion and use this information
for further projects.

8.3 Select baseline

To select a basic plan, please proceed as follows:

1. Click Project > Baseline > Select. The Select baseline dialogue opens.
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2. Click in the Name field by the arrow.

3. Select the desired baseline from the list.

4. Click on the button OK.

8.4 Dynamic baseline

As a project is continually being developed and updated, none of the saved baseline plans, which is only a momentary
recording the project status, can provide a complete overview.

Here comes a so-called dynamic baseline plan to help, which is automatically generated from all stored baselines.

The selection of which baseline to use as a reference baseline for each activity is done automatically according to the
following rules:

• If a Completed Percentage of an activity is equal to zero, the last saved baseline in time is taken as reference in
a Dynamic Baseline for this activity.

• For the activities that have a Completed Percentage greater than zero, the base plan selected for each activity is
the one that was saved last before the percentage was entered for each activity.

Note: Requirements for a dynamic baseline

1. Save baselines

2. Maintain completed percentage or effort

Tip The more baselines are stored in a project, the more accurate a Dynamic Baseline will be. A disadvantage of this
is that the size of a project increases with each baseline.
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8.5 Delete baselines

In order to delete a baseline, do as follows:

• Select the menu item Project / Delete baseline. The dialogue box Delete baseline opens.

• Choose the baseline you want to delete from the drop down list
Name.

• Click on the button OK.

8.6 Variance analysis

A variance analysis helps you to identify differences between actual and target. The table and the diagram show you
and highlight all parameter deviations from actual and target.

In order to do a variance analysis, do as follows:

• Activate the tab General and choose the preferred baseline from the drop down menu Baseline.

• Select a previously saved baseline and select the menu item Project > Baseline > Select.
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• Click on the button OK.

• Select the menu item Start > Activity views > Variance analysis. The Variance analysis opens:

The first row in the table lists the properties of the scheduled activities and subprojects (TARGET), while the second
row lists the actual properties of the activities and subprojects (ACTUAL). Parameters deviating from the baseline are
marked in yellow.

Note: Detailed information about the variances can be obtained by marking the activity in the table (see green arrow)
and selecting the corresponding tabs in the box Object properties.

Only difference
Select the menu item Variance analysis Format > Show > Only difference. This option turns off all activities, where
there is no difference. So you can get only relevant information to the Variance analysis.
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Progress line of the project
A progress line displays graphically deviations of the cutoff date that occurred between the actual project status and
the selected baseline and is displayed in the Variance analysis.
Ideally, a progress line accords with the marked cutoff dates and runs vertically across the variance analysis. A progress
line running left from the cutoff date indicates a delay in the project course.

A progress line running right from the cutoff date, indicates that some activities of the project will be completed earlier
than scheduled.

In order to visualise the progress line of a project, select one of the following menu items Variance analysis > Progress
line

• Start date
• Finish date

8.7 Control of project financing

In order to evaluate the project financing, proceed as follows:
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• For the gantt chart open an additional break-even chart in the menu
item Start > Additional views > break-even chart.

• Record all expected incoming payments by setting a separate milestone at the date of invoice.

• The break-even chart contrasts the actual costs with the financing. The the invoices dates are marked at the curve
Actual costs.

Note: The financing can be displayed by either the invoices dates or the payment term.

• You can toggle between the menu items Financing - Invoice date and Financing - Term of payment.

• Similar to the date of invoice, the dates identical with the payment term are highlighted at the curve Actual cost.

The financing control allows you therefore to detect investment risks (advance financing).
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NINE

PROJECT MANAGEMENT

You can use Rillsoft Project 6.1 for the following tasks, so as to accomplish the successful completion of your project
targets or even exceed them and prevent the schedule from getting delayed or, at least, mitigate the consequences of
possible risks:

• separation of completed activities from waiting activities.

• shifting of delayed activities to the cutoff date (actual date).

• assignation or reassignation of employees to and from activities in the ongoing project.

• assignation of employees to critical activities to speed up execution.

• optimisation of resource utilization of not yet completed project activities.

A project sample before updating

Separation of completed activities from waiting activities
• Rightclick on the activity and select from the context menu the command Split > From complete supply .

Shifting of delayed activities to the cutoff date (actual date)
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• Set the cutoff date.

• Enter the completion percentages of all activities.

• Select the menu item Project > Schedule > Other functions > Move delayed activities to cutoff date.

Assignation or reassignation of employees to and from activities in the ongoing project

• Mark the activity.

• Activate the tab Employees in the window Object properties.
• Remove the employee from the activity.

• Click on the button OK.

Alternatively: You can remove an employee from several activities at a time. Select the menu item Project > Assistant
> Employee > Remove the employees from the activities.

Assignation of employees to critical activities to speed up execution
• Mark the critical activity.

• Activate the tab Employees in the window Object properties.
• Assign more employees to the activity.

• Click on the button OK.

Optimisation of resource utilization of not yet completed project activities
• Set the cutoff date.

• Enter the completion percentages of all activities.

• Select the menu item Project > Schedule > Other functions > Optimise resource utilization.

Note: Delayed activities will be automatically shifted to the cutoff date during the optimisation of resource utilization.
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TEN

PRINT

10.1 Printing

You can print all views of a project and report about the project schedule and project resources.

• Select the view according to your requirements.

• Check the content in the preview field.

• Print the document.

Select either view or report
You can select a view by clicking the menu item Start and one of the activities, resource or capacity views.

Print preview
In order to obtain a print preview, do as follows:

• Choose the menu item File > Print.
• Check the appearing dialogue Print preview and correct the parameters, if necessary.

• Click on the button OK.

Printing
There is a number of ways for how to print a document:

• Select the menu item File > Print. . . .
• After checking the print preview, click on the button Print.
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10.2 Print preview

You can print the project details as views or tables as they are shown on your screen.

After editing the project details (filter, formatting,view changing, etc.) in the preferred view, you can check the layout,
that is, the positions of the project details in the print preview.

For this purpose, you can use the page view function, which shows either a single page or several pages in a small scale
of depiction. Project details can not be edited in the page view modus.

You can use the menu item File > Print to define the print settings.

Among others, you can fit a project schedule to one or several pages by entering the preferred number of pages in Scale
and marking the check box Fit to page size.

298 Chapter 10. Print



Rillsoft Project, Release 9

10.3 Print view

Rillsoft Project offers the following views:

• Activities views

– Gantt chart

– Variance analysis

– Network chart

– Gantt-network chart

• Resource views

– Role usage

– Team usage

– Employee workload

– Material requirements

– Machine types

– Machinery

• Capacity views

– Human resource capacity planning

– Machine capacity planning

In addition, you can create your own views.

In order to print a view, do as follows:
• Select the view that contains the information you want to print.

• Edit the header / footer for the project printing.

• Select the menu item File > Print.
• After checking the print preview, click on the button Print.

Header and footer
• In the window Project properties, select the tab Header and footer.

• Click on one of the six text boxes to which you want to add the information and enter a text. You can also add
project details from the drop down menu Fields.

• If necessary, repeat step 2 for all other boxes.

• Alternatively, you can add texts and graphics, (such as Logo-Picture) from the clipboard.

• You can also add project details from the drop down menu Fields.
• Click on the button OK.
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Edit the view you want to print
Quite often the document looks differently on the screen than in the print preview. You can do the following: - define
the type and size of the font in the text field - add/remove entries from headers / footers - change text and bar displays
- enlarge or reduce vertically

View as PDF file
In order to print as PDF file, you need to

• install a PDF printing device (such as Adobe Installer or a free program)

• Prepare a view for printing (see above)

• Select the menu item File > Print.
• Define an available PDF printing device in the dialogue Print above the list field Printer.

• Click OK.

10.4 Print holiday report

You can print non-working days of the employee for a requested period as a pdf-file.

Note: Non-working days should be registered in the Resource pool for employees.
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• Create a project with a beginning and an end, which defines a reporting period. For example,the 01.01.2016 is
the beginning and 31.12.2016 is the end

• Click on Start > Resource views > Employee

• Select the menu item Start > Outline > Structure and define the employee structure. For example Team >
Employee

• Define the time scale. For example, day 1:1
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• Check which columns should be displayed, by selecting the menu item Employee format > data > columns and
switch on/off the required columns.

• Click Start > Edit > Filter and delete a marker of To choose only planned resources from offer option

• Select the menu item File > Print and define print settings.
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ELEVEN

CUSTOMIZE PROGRAM ENVIRONMENT

11.1 Adjustments of the program environment

You can adjust Rillsoft Project’s environment parameter via the menu item File > Options . . . . The following param-
eters are adjustable:

• Tab General Adjusting the default parameter

• Tab Display Adjusting the size, the font, the color etc. of the different objects

• Tab Extended Adjusting the settings for the appearance of the tabs in views, avtivity properties and
project/subproject

• Tab Customize Ribbon Adjusting the Ribbon

• Tab Quick Access Toolbar Adjusting the Quick Access Toolbar
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11.2 General

General
Rillsoft-Design: Select color scheme for the program.

Default location You can create folders for reports, projects and templates.

• Projects: Select a folder for the projects

• Portfolios: Select a folder for the portfolios
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• Templates: Select a folder for the templates

• Reports: Select a folder for the reports

Default parametrs for a new activity
• Fix Duration - If you select this option, the effort and the utilization of the resource is calculated, while the

activity’s duration remains possible. You should select this option if you are planning on the basis of the well-
known activity duration. The resource effort is then automatically calculated.

• Fix Effort - If you select this option, calculates the resource utilization and activity duration while the effort
remains constant. You should select this option if you are planning on the basis of the known activity effort for
activity roles. The activity duration is calculated automatically.

• Duration - Specify the default value for new activities.

• Disregard team and employee calendar - Select this check box if team and employee calendars should not be
included in new activities.

• Start of activity only at first shift - Select this check box if the start of the activity may begin only on the initial
layer.

Extended
• Show help - Select this check box so that the help of all objects is displayed.

• Cutoff day move to actual day - Mark this check box to automatically set the cutoff date on the actual date.

• Label resource chart - Mark this check box to label the resource bars on the resource chart with the actual value.

• Represent weekend - Select this check box to represent weekends and holidays in the views.

• Represent nonworking days - Select this check box to represent nonworking days in the views.

• Reserve time calculation - Mark this check box to automatical calculation when project changes to the contin-
gency reserve in activities. If this option is switched off, earliest- and latest possible start- and end of activities
in the activities table are not represented.

• Auto restore: - Enter the time interval in which a backup of your project must be created.

• Currency: - Enter the currency code.

• Undo depth: - Enter in this field a value for undo.

• Activities are critical, if buffer is smaller or equal: - You define a value, when the activities should be consid-
ered critical.

• Read-only projects in the portfolio of grey - When a portfolio is opened, read-only projects are represented in
grey colour.

Rillsoft Integration Server:
You can set the settings for working with Rillsoft ntegration Server.

• Enter commit comment for project versions - You can add comments for each project version.

• Timeout - Enter in this field a value for the time spent waiting for a response from the Rillsoft Integration Server
before either has to be transmitted again or the connection with a (timeout) error is cancelled.

• HTTP authentication - authenticate for Webserever, where among other things, Rillsoft Integration Server is
installed for more access.

– User name Enter the user name to connect to the Web server. Important: It is not a user name for Rillsoft
Integration Server!

– Password Enter the password to connect to the Web server. Important: It is not a password for Rillsoft
Integration Server!
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• Use proxy server for your LAN You can configure Rillsoft project that there is a connection to the Rillsoft
Integration Server by a proxy server.

– Address Enter the address of the proxy server.

– Port number Enter the port number.

– User name Enter the user name to connect to the Rillsoft Integration Server.

– Password Enter the password to connect to the Rillsoft Integration Server.

11.3 Display

You can adjust color and size of the different objects.
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The parameters are mostly intuitively understandable.

View
Lineal Left you can define the font in the additional diagrams such as resource or Gantt chart.

Change font and font size
You can change the fonts and font size to views, such as the chart area, as well as the table.

• First, click the menu item File > Options > Display
• Select the desired options
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11.4 Extended

You can change the settings which tab pages in the following areas should be represented.

• View - Select the views from the list to be displayed.

• Activity properties - From the list select the activity properties that you want to appear as tabs at the top of the
activity properties window.

• Project/Subproject’s properties - From this list select the project/subproject properties that you want to appear
as a tab in the upper pane of the project properties window.
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11.5 Customize Ribbon

You can customize the Ribbon according to your requirements, e.g. create custom tabs and groups that contain com-
monly used commands.
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11.6 Quick Access Toolbar

You can customize the Quick Access toolbar at two different positions, for example, below or above of the Ribbon
place, as well as add buttons to it, that are representing the commands. Only commands can be added to the Quick
Access Toolbar.
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